[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-users] Trouble with gpsd and systemd

From: Ekki Plicht (DF4OR)
Subject: [gpsd-users] Trouble with gpsd and systemd
Date: Tue, 8 Jan 2013 15:31:56 +0100


To be very clear about this - this is no problem with gpsd, not a bug in gpsd, but some problem in conjunction with systemd. Since neither the Arch Linux forum nor the systemd-Community on G+ could provide any insight, I am trying my luck here. Please bear with me.

Maybe someone here has already some experience with gpsd and systemd.

I am using Arch Linux. Just upgraded from traditional SysV initscripts to systemd, most went ok but one problem remains.

When I start the gpsd daemon, the log gets filled up _very_ rapidly with:

JanĀ  4 01:09:49 grappa systemd[1]: Starting GPS (Global Positioning System) Daemon...
JanĀ  4 01:09:49 grappa systemd[1]: gpsd.service start request repeated too quickly, refusing to start.

The service does not start, systemd tries to restart it several 1000 times a second. This only stops when I stop the service with systemctl.

I have copied the provided gpsd.service file from /usr/lib/systemd/system/ to /etc/systemd/system/ and modified that file to reflect my local hardware. The only line I changed in the gpsd.service file is:

ExecStart=/usr/sbin/gpsd /dev/ttyS2

When I start the gpsd daemon manually without systemctl everything works as expected (as it did before migration to systemd).

What I tried so far:
- more diagnostics from gpsd, no joy, no output
- added explicit 'Type=simple' to gpsd.service, no joy
- added 'RestartSec=10', 'Restart=no', 'StartLimitBurst=1' to reduce at least the restart rate, no joy.
- checked prmissions on the serial device, looks good
- asked in the german arch linux forum, no reply
- asked in system Community on G+, no useful hint

Any ideas what could cause this issue?

Versions used:
gpsd: 3.7-1
systemd: 196-2
kernel: 3.6.1-1-ARCH (Standard Arch Linux kernel)

The GPS device is connected to /dev/ttyS2, it's a traditional serial interface, not USB. It worked nicely before the upgrade to systemd, it still works nicely when I start the daemon without systemd.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]