[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] Compiling gpsd3.3 under CentOS4.9

From: Eric S. Raymond
Subject: Re: [gpsd-users] Compiling gpsd3.3 under CentOS4.9
Date: Tue, 10 Jan 2012 13:09:34 -0500
User-agent: Mutt/1.5.21 (2010-09-15)

Greg Chisholm <address@hidden>:
> I got gpsd3.3 to build under Centos4.9, with some gymnastics.  Following the
> requirements listed in build.txt, I installed chrpath from the Centos "extras"
> repository:
>   # yum install chrpath

Good, I'll note that in the build instructions.
> For scons, I used the scons 2.1.0 rpm from,
> however, it insists on python >= 2.4 (only 2.3 is available from the
> repos), so I installed it with '--no-depends':
> # rpm -ivh --nodeps scons-2.1.0-1.noarch.rpm
> I also tried scons 1.2 (available from the repos, but it bombed).

Not surprising.

> At this point running scons will choke on line 350:
> # scons
> scons: Reading SConscript files ...
>   File "/root/ntp-gps/gpsd3.3/gpsd-3.3/SConstruct", line 350
>     with open("xmltest.xml", "w") as ofp:
>             ^
> SyntaxError: invalid syntax

Right, as you discovered this is a Python-version ssue.

> It turns out that the SConscript file needs Python 2.5+,

This is noted in the build instructions.

> The scons build 'almost' worked at this point, I had just one more issue.
> My version of gcc didn't recognize the flag '-Wno-missing-field-initializers'
> so I removed it from SConstruct (around line 245):
>         -Wno-missing-field-initializers -Wcast-align
> changed to:
>         -Wcast-align
> gcc version info: "gcc version 3.4.6 20060404 (Red Hat 3.4.6-11)"

Thanks, added to the build instructions.

> I was able to build and install the binaries, but I didn't get the
> docs to build.  At least gpsd and gpspipe are working, and, because
> that's
> all I care about, I stopped there.

Thanks for the heads-up.
                <a href="";>Eric S. Raymond</a>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]