[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] Building gpsd 3.3

From: Eric S. Raymond
Subject: Re: [gpsd-users] Building gpsd 3.3
Date: Tue, 10 Jan 2012 12:35:54 -0500
User-agent: Mutt/1.5.21 (2010-09-15)

Pris Matic <address@hidden>:
> I'm trying to build gpsd (my distro has a gpsd package that works
> fine, but I need to modify source). I'm running Arch Linux x86, kernel
> 3.1 (latest stable). I tried to follow the build instructions but ran
> into many problems.

Man, you seem to have been seriously snakebit.  Let's see how many of these 
we can solve...
> 1) Running scons inside the build directory errors out with the following:
> gpsd :/usr/bin/ld: ntpshm.o: undefined reference to symbol
> 'log@@GLIBC_2.0'.... /usr/bin/ld: note: 'log@@GLIBC_2.0' is defined in
> DSO /lib/ so try adding it to the linker command line
> I tried adding LDFLAGS=-lm to my environment in the SConstruct file,
> my shell environment, even directly passing the argument to scons when
> I called it but none of these methods worked.

This is *probably* fixed by the new fallback to static linking if chrpath
is not installed.  I'd appreciate it if you'd pull git head and check.
> Then I commented out line 805 and unindented line 806 in SConstruct,
> and gpsd seemed to build without any more errors. I don't know what
> the implications of changing those lines were.

I don't either.  Sconstruct must have changed substantially since you
tried this, as these lines don't seem to point to aanything interesting now.

> 2) I tried running scons testregress. Every single test (all 74)
> fails. I added "." in my path, like the build docs say. I also tried
> running testregress after installation, but this fails as well.

This remains mysterious to me.  It might go away due to the static-linking

> 3) I decided to try running gpsd anyway, using xgps to verify it was
> working okay... which gives me this error:
>   File "/usr/local/bin/xgps", line 624
>     Base.gpsfields = map(lambda ((label, hook), widget): (hook, widget),
>                                 ^
> SyntaxError: invalid syntax

What version of Python are you running?  It's probably either very new or
very old.  I dimly recall something about this kind of argument templating 
no longer working in 3.x, so I may have to change that code.

> 4) Finally, I try checking gpspipe's output, and it looks like gpsd is
> actually working, which is great.
> Is everything okay at this point? (can I get xgps working somehow
> too?) Or is gpsd going to break on me at some point because I couldn't
> complete the build process properly?

The fact that gpspipe is working means that gpsd itself is OK.  Your
problems are all in the build recipe and Python.  We should be able
to fix those.
                <a href="";>Eric S. Raymond</a>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]