[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-users] Unable to get gpsd to work with NTRIP

From: Bradley Allen
Subject: [gpsd-users] Unable to get gpsd to work with NTRIP
Date: Thu, 1 Dec 2011 09:57:59 -0800


Ive recently installed GPSD into a new Ubuntu 11.10 64b system
(already tried on a few other linux installs).  I got the gpsd by
going into software updater, searching for gpsd then installing it.
It shows version 2.95 ?  but if I follow the official gpsd site to the
source code it shows its version 3.3?  i got the source and tried to
compile but it errors out.

with gpsd installed, i have a GPS receiver connected to my usb port,
it shows up as /dev/ttyACM0  and if i open a serial port terminal i
can see the data filling the screen once per second.  i have tried
variations of:

gpsd /dev/ttyACM0 with different options, where it either returns with
no message or says
gpsd: can't bind to IPv4 port gpsd, Address already in use
gpsd: maybe gpsd is already running!
gpsd: can't bind to IPv6 port gpsd, Address already in use
gpsd: maybe gpsd is already running!

I then try to telnet localhost 2947 and it shows up:
address@hidden:~$ telnet localhost 2947
Connected to localhost.
Escape character is '^]'.

then i type in, per instructions,
 ..and the reply is

I try cgps or xgps and it brings up a screen with empty information, i
expect at least the time but its empty as in not connected.

I try to connect to my NTRIP server  saying gpsd
ntrip://admin:address@hidden:2101 /RTCM1819

and it returns with no message.  I check my NTRIP server and no
attempt was made to connect.  Ive tried a few variations on typing
this in also.

The goal is to have a NTRIP ready GPS unit connect up and get the feed
from the NTRIP server and show me very accurate position info.  Have
tried for many days now, any hints or suggestions are so greatly
appreciated, THANKS!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]