gpsd-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

failure to build gpsd on aarch64 system.


From: Bart Nielsen
Subject: failure to build gpsd on aarch64 system.
Date: Mon, 19 Jun 2023 15:26:06 -0400

This is mostly a vanilla 64 bit installl of a raspbian system.  I’ve added a 
few packages based on the suggestions in abuild.doc


E: Package 'python-gi' has no installation candidate
E: Unable to locate package python-gi-cairo
E: Unable to locate package pyserial

E: Unable to locate package python-cairo-dev
E: Unable to locate package python-gobject-2-dev
E: Package 'python-serial' has no installation candidate


This code has always had issues with matplotlib, which I don’t understand.

 apt install python3-matplotlib


seems to do something useful.

This ends with:



cp gpsd-3.25/example_aiogps.py tmp.py; /usr/bin/python -tt -m py_compile tmp.py;
  File "tmp.py", line 23
    async def get_gps_updates(gpsd: gps.aiogps.aiogps) -> None:
            ^
SyntaxError: invalid syntax

scons: *** [gpsd-3.25/python-compilation-regress] Error 1
scons: building terminated because of errors.
WARNING: gpsplot is missing required runtime module matplotlib
WARNING: xgps and xgpsspeed are missing runtime dependencies
Ensure your PYTHONPATH includes /usr/local/lib/python3/dist-packages/
monet@pi1:~/src/gpsd-3.25$ 



Which is at least a new error.

What would you actually like to see?

Thanks,

Bart




reply via email to

[Prev in Thread] Current Thread [Next in Thread]