[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Firefox Sync disabled - why?

From: bill-auger
Subject: Re: Firefox Sync disabled - why?
Date: Wed, 15 Jan 2020 12:58:33 -0500

On Wed, 15 Jan 2020 13:58:45 +0100 Jakub wrote:
> - The feature is not SaaSS - synchronising data between
> devices is not something that could be done locally.

of course it is SAAS - the sync service is not providing any
functionality that one could not accomplish themselves manually
- it is just a convenience - long before any browser had such a
sync service, one could easily export their bookmarks to a text
file, for importing into another browser instance; and icecat
still has that functionality

for someone who installs the browser freshly on many systems very
often, there is a considerable value to that convenience; but
that is something that most people do so infrequently that the
benefit is negligible - bookmarks are the only data in that
store that i would consider as "data" - the others are for
real-time synchronization of the state of the browser itself;
which is hardly a necessity

another thing that is worth noting is that the current release
of GNU icecat (60.7.0esr) does have the sync feature enabled -
the version in the guix repos is not a gnuzilla release; so the
grievance should be directed at guix

this would be relevant to discuss on this list if yet unreleased
gnuzilla v68 explicitly disables that feature, or it is planned
to - if it does, we will probably re-enable it in the parabola
builds; because it has value to some people, and i have seen no
indication that it runs afoul with GNU standards or with the FSDG

to the original "why" question, i really dont know the answer,
or if it was ever done intentionally - in the past, the sync
feature has worked in some icecat releases and not in others;
and i have always assumed that it was a bug - it has been
reported as a bug many times on the gnuzilla mailing list and on
savannah over the years[1][2] - in at least one of those
instances, the problem was that librejs was blocking it somehow;
and it worked as expected with the librejs add-on disabled


reply via email to

[Prev in Thread] Current Thread [Next in Thread]