[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[libmicrohttpd] 01/06: mhd_threads: muted compiler warning on W32
From: |
gnunet |
Subject: |
[libmicrohttpd] 01/06: mhd_threads: muted compiler warning on W32 |
Date: |
Mon, 11 Sep 2023 18:51:48 +0200 |
This is an automated email from the git hooks/post-receive script.
karlson2k pushed a commit to branch master
in repository libmicrohttpd.
commit e71a6a5dff27a8816129fa16bb0e7cedce3acc06
Author: Evgeny Grin (Karlson2k) <k2k@narod.ru>
AuthorDate: Thu Sep 7 21:08:19 2023 +0300
mhd_threads: muted compiler warning on W32
---
src/microhttpd/mhd_threads.c | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/src/microhttpd/mhd_threads.c b/src/microhttpd/mhd_threads.c
index 95fc70a6..1f6ac09e 100644
--- a/src/microhttpd/mhd_threads.c
+++ b/src/microhttpd/mhd_threads.c
@@ -218,6 +218,7 @@ MHD_create_thread_ (MHD_thread_handle_ID_ *thread,
return ! res;
#elif defined(MHD_USE_W32_THREADS)
+ uintptr_t thr_handle;
#if SIZEOF_SIZE_T != SIZEOF_UNSIGNED_INT
if (stack_size > UINT_MAX)
{
@@ -225,14 +226,13 @@ MHD_create_thread_ (MHD_thread_handle_ID_ *thread,
return 0;
}
#endif /* SIZEOF_SIZE_T != SIZEOF_UNSIGNED_INT */
-
- thread->handle = (MHD_thread_handle_) (uintptr_t)
- _beginthreadex (NULL,
- (unsigned int) stack_size,
- start_routine,
- arg,
- 0,
- NULL);
+ thr_handle = (uintptr_t) _beginthreadex (NULL,
+ (unsigned int) stack_size,
+ start_routine,
+ arg,
+ 0,
+ NULL);
+ thread->handle = (MHD_thread_handle_) thr_handle;
if ((MHD_thread_handle_) - 1 == thread->handle)
return 0;
--
To stop receiving notification emails like this one, please contact
gnunet@gnunet.org.
- [libmicrohttpd] branch master updated (dfbc4da6 -> 97707d77), gnunet, 2023/09/11
- [libmicrohttpd] 01/06: mhd_threads: muted compiler warning on W32,
gnunet <=
- [libmicrohttpd] 02/06: mhd_threads: fixed check for error when starting a new thread on W32, gnunet, 2023/09/11
- [libmicrohttpd] 03/06: mhd_threads: renamed one macro for clarity, gnunet, 2023/09/11
- [libmicrohttpd] 04/06: Renamed 'pid' -> 'tid' when used for threads, gnunet, 2023/09/11
- [libmicrohttpd] 05/06: mhd_threads: added new macro MHD_join_thread_tid_(), gnunet, 2023/09/11
- [libmicrohttpd] 06/06: mhd_str: fixed possible compiler and run-time sanitizers warnings, gnunet, 2023/09/11