[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnumed-bugs] a query problem when bootstrapping bundle [v18-v19-dynamic

From: Busser, Jim
Subject: [Gnumed-bugs] a query problem when bootstrapping bundle [v18-v19-dynamic]
Date: Sun, 17 Nov 2013 19:47:07 +0000

Under PostgreSQL 9.1

1) I previously reported being able to bootstrap through to v19. I do not believe the fact that it paused at v18 on account of an error I made adjusting a script caused any difference. Nor that I attempted, then gave up, trying to insert an old v18 backup into the process. In the end, I did a DROP of that db, and I then upgraded the bootstrapper's v17 ... v18 and then v18 ... v19. I have been able to access with v19 using client 1.4.0.

So we know that under PostgreSQL 9.x it is possible from the tarball to bootstrap a test database up through v19.

2) We do not yet know, AFAICT, whether anyone has been able to upgrade a v18 (PostgreSQL 8.4) database up into v19 (PostgreSQL 9.x).

I tried today, by bringing over -- onto my test machine with PostgreSQL 9.1, a fresh production v18 database backup (which I had prepared under PostgreSQL 8.4).

I ran into a problem that relates to preparation for specifying a praxis branch.

What I need help with is whether I need to fix something in my own v18 because of some issue with how the orgs and branches have been set up, or if the problem is in the query that is used by v18-v19-dynamic in failing to adequately resolve a subquery.

Log attached.

Might it have anything to do with the fact that I had imported, into my v18 org structure, 12,000 physician offices?

-- Jim

Attachment: failed upgrade to v19 update_db-v18_v19.log
Description: failed upgrade to v19 update_db-v18_v19.log

reply via email to

[Prev in Thread] Current Thread [Next in Thread]