[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GNUe on Suse Linux 7.1

From: Michael Goebel
Subject: GNUe on Suse Linux 7.1
Date: Wed, 21 Aug 2002 17:24:44 +1200

Hi there, my name is Michael Goebel.
I am very happy to report that GNUe works on my Suse 7.1 distribution
with kernel 2.4.0.
I tried both version 0.3.0 and the latest cvs snapshot (I couldn't find
gnue-navigator anywhere in 0.3.0).

First I have to say that the effort was well worth it. After the
installation was complete
(two days), I looked for about half an hour so at the form samples.
After that I had written my
first functional database form in less than 10 minutes. And it worked !!
I already wonder
what I will be able to do once I have actually read the documentation :)

Below is how I did it. Note that I am not a professional syadmin, and
until two days ago
I had never heard of Python or Qt or Gtk. I guess what I'm saying is
that there may well be
a better way of doing this. However, here is what worked for me:

------------------ snip ------------------

- I already had a running PostGresql 7.2.1, downloaded from,
  compiled from source with "configure --enable-syslog",
  the server is started with the "-i" option for accepting TCP/IP

- Need Python:
  Using Yast, install packages pygresql, python-curses, python-devel,
python-demo, python-gtk, python-gdbm,
  python-xml, python-gnome, python-imaging (Series d, Suse

- Need from egenix:
    - download + untar egenix-mx-base-2.0.3.tar.gz from
    - as root: run "python install" -> installs into

- Need PyGreSQL (Postgres client interface for Python):
    - Making postgres with "configure --with-python" failed because some
header files couldn't be found
    - in directory postgresql-7.2.1/src/interfaces/python:
      "gcc -O2 -m486 -fpic -I/usr/include/pgsql -I ../../include
       -I ../libpq -I/usr/include/python2.0 -c pgmodule.c -o
    - as root: "python ./ install" -> installs into
    - test: "python" >>> import _pg
                     >>> db =
                     >>> db.query("INSERT INTO testtable
(column1,column1) VALUES ('ping','pong')")
                     >>> db.query("SELECT * FROM testtable")
            (must have no spaces at beginning of python

- Need wxPython (here I had to experiment for a while): 
    - download glib-devel from
      - install with "rpm -Uvh glib-devel.rpm"
    - download gtk-devel from
      - install with "rpm -Uvh gtk-devel.rpm"
    - download wxPython-2.3.1-1-Py20.i386.rpm from
      - rpm complains that is needed by
wxPython-2.3.1-1  ->
        - download wxGTK-2.3.1-2.i386.rpm from
        - install with "rpm -Uvh wxGTK-2.3.1-2.i386.rpm"
      - install with "rpm -Uvh wxPython-2.3.1-1-Py20.i386.rpm" -> now it

- Download GNUe files from, unzip+untar. 

- as root: In each subdirectory (common, forms, ...) run "python install" -> installs into /usr/local/gnue

- Configure GNUe:
  in /usr/local/gnue/etc/":
  - "cp sample.gnue.conf gnue.conf"
  - "cp sample.connections.conf connections.conf",
    add database section in connections.conf:
    There must be no comments like "# this is the host name" or so after
the entries,
      otherwise I got an error "Unknown provider
'postgresql                # comment'".
    Also, no line "encoding=ASCII", otherwise postgres complains about
unsupported options.

- That's it -> test it by running the forms in the sample directory.
  If in GUI trouble, try passing "--debuglevel=10" as a parameter to
  If in database trouble, also take a look at the postgres logfile.
------------------- snip -----------------------

Have fun,

> Open Questions:
> ===============
> Q: What about other linuxes or other *n*x platforms?
> A: Well! What about them? Tell me!
>    Some core developers use RedHat Linux, so it works. They had some
>    trouble with some libraries and a fix was on the mailing list, look
>    at the archive.
>    If you manage to install gnue(f) on another platform please publish
>    the recipe to the gnue mailing-list or as a last resort to me
>    (address@hidden).                                                          
>    Platforms gnuef is known to work on:
>      RedHat Linux
>      Debian GNU/Linux
>      Solaris 2.5.1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]