[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GEAS database error

From: Derek A. Neighbors
Subject: Re: GEAS database error
Date: Sat, 02 Feb 2002 09:22:03 -0700
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917


Has anyone answered this for you yet?

Richard Rosenberg wrote:

Hello All. . .
Everything has gone (relatively) smoothly up to this point. . .however when I run in the geas/src directory I get an error saying that 'no backend database can be found'. I have tried running './configure --with-postgresql. . .' specifying the path to postgresql data (in my case, /var/lib/pgsql/data) and the build option = 'localhost'. When I run it through ./configure, I get what might be a more discreet message, telling me that libpq-fe.h cannot be located. There is no object with that name on my system, though I have seen messages referring to it in the list archives. I have installed all of the postgresql 7.1.3 packages I could get my hands on. I have initialized the database, created a user (hacker, w/no password), created a database (empty) called 'gnue', and manually started the postmaster using the '-i' switch and even tried specifying the port. I can succesfully connect to the 'gnue' database a few different ways at the console, using either the 'postgres' logon or using the 'hacker' account I set up. I am running Redhat 7.1, PostgreSQL 7.1.3, and Python 2.1. I have a few 'libpq*' objects around, but no libpq-fe.h. Any assistance is greatly appreciated.

libpq-fe.h should be in the PostGRES 'devel' packages. Make sure you have those installed.

address@hidden:~$ rpm -qa | grep postgres

postgresql-devel-7.x.x-x should be where it resides...

In fact you can find it here ( and it confirms that it contains libpq-fe.h


reply via email to

[Prev in Thread] Current Thread [Next in Thread]