[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Lilypond 1.4.4 bugs and some (hopefully) helpful stuff

From: William R. Brohinsky
Subject: Lilypond 1.4.4 bugs and some (hopefully) helpful stuff
Date: Thu, 28 Jun 2001 12:19:30 -0400

Notes on 'virgin' install of cygwin and lilypond 1.4.4:

First, I tried to make my win2K machine clean of all old lilypond,
cygwin, gsview, ghostview and miktex stuff, so I could install cygwin
and lilypond 1.4.4 afresh. Notes on what I did to clean up my system
below, immediate actions needed to get 1.4.4 working here:

The file still contains the error: 
which causes an error when LaTeX is called (or any other MiKTeX
The fix has been discussed here before, simply removing the
portion allows the following loop to properly assign the directory.

-Once latex.exe can be found, ly2dvi still exits with an error.
The cause is that miktex hasn't been configured properly. Going to
and running config.bat spams the window with lots of output, 
but after that, ly2dvi -P completes without error
and produces the desired files. (can this be automated?)

-running >gsview32 brings up gsview32 with the following 
 Ghostscript cannot be found on your computer. You will need
 to download and install ghostscript from
 <begin text box>
 <end box>
 <download now> <cancel> <help>

Cancelling this box and going through the registration nag box, 
you can select the options/advanced config menu, and enter the


The third box on this requestor didn't seem to need changing, but could
indicate that I have more things to eradicate before I have a virgin

However, at this point, gsview32 displays just fine!

(Whether this can be automated or fixed with external path or
environmental directives is beyond me. Someday, I will actually know
what I'm doing! (of course, by then, I'll be doing something

Notes on cleaning out Win2K:

We can all expect that by the time Lilypond is out of beta, the
installers will ensure that an installation 
or upgrade will ensure that the entire system is set up properly,
without interference from preexisting
installations. Until that time, for windows users, here is my own
procedure for arriving at a 
fairly-virgin starting point:

Beneficial note: I generally maintain a local directory of install
files. This is easy, with the 'download
to local directory' option in setup.exe. I keep the cygwin and lilypond
install directories separate, although this
might not be necessary. I recommend this, if you have the disk space
(and who doesn't these days? It only takes about 90 megs
as of this writing, and is very likely to make life easier if you have
to reinstall from scratch.

Uninstalling old versions:

Run lilypond setup.exe using what ever you used for the original install
(ie, I ran setup and 
downloaded from internet to a local directory, then ran it again to
install from local directory. 
The appropriate action would be to `install from local directory').
Click the full/part button
for a complete listing, then click each entry to 'skip' or 'uninstall'
as appropriate. ( they seem to be 
mutually exclusive.) Complete to uninstall what is there.

Do the same for the cygwin setup.exe.

Run start/settings/control panel/"add/remove programs" and ensure that
any vestigial miktex, gsview or ghostgum or 
ghostscript, python, cygwin, or any other programs associated with
cygwin and/or lilypond are removed.

[Disclaimer: abuse of Regedit can damage your computer's ability to
boot, run programs, and function reasonably even
more than installing windows 95/98/nt/2K does! Do not use regedit if you
don't understand what you are doing, and 
don't think you can hold me liable because I say to use it here: I'm
only actually saying I used it, and I'm not even 
encouraging anyone else to do so!]

With regedit (or some other appropriate tool) remove all registry
entries related to cygwin and lilypond.
In each case, search on the search text, and delete the highest folder
in the tree with a recognizeable
reference to the associated software:
search text                     associated software
lily                            lilypond
python                          python
MiK                                     MiKTeX
cygwin                          cygwin
This set seems to be sufficient. (note that the c:\gs directory and
possible others might have to be expunged.)

NOTE: You can modify the path strings from here. If you do, you don't
have to do it later. But if you do it wrong, 
all the same disclaimers apply.

Move any files of importance to you out of the cygwin tree (such as
/home/<user dir>) and delete c:\cygwin

Delete any directory trees under C:\program files\ for MiKTeX, Python,

Clean up the PATH and other environment variables. (This can be accessed
by right clicking my computer and selecting
properties. THe resultant window has tabs on it. In win2K, the relevant
tab is 'advanced', and the middle button 
leads to the environment strings. I don't remember what it is in win98
anymore, but it should probably be from a 
button on the last tab.) Ensure that all references to cygwin, MiKTeX,
python, ghost* are gone.

NOTE the disclaimers above!

Now, it the system should be cleansed.

Update your store of install files by running setup.exe for lilypond
(and/or cygwin), and install afresh.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]