[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lilypond-book crash (was: Re: line breaking in lilypond-book)

From: Laura Conrad
Subject: lilypond-book crash (was: Re: line breaking in lilypond-book)
Date: 11 Jun 2001 18:48:18 -0400
User-agent: Gnus/5.090004 (Oort Gnus v0.04) XEmacs/21.1 (Cuyahoga Valley)

>>>>> "Mats" == Mats Bengtsson <address@hidden> writes:

    >> The attached file does what I expect if I run ly2dvi on it.  The
    >> spacing isn't optimal, but it comes out on 2 pages.  However, if I
    >> use it as a \lilypondfile in the attached .lytex file and run
    >> lilypond-book on it, it claims it can't find a good spacing, and comes
    >> out with lots of really sparse lines on 4 pages. 

    Mats> Interesting! The problem is not lilypond-book itself but that it
    Mats> set the line width to 390pt. With that linewidth it happens that 
    Mats> the (invisible) bar line where Lilypond wants to break the line 
    Mats> falls in the middle of a note because of Morley's intricate
    Mats> rhytms.

That would explain why the problem went away when I made a pretty
minor change to the lilypond.  But it makes me nervous that this can
pop up at any time.  (I think it happened when I added the custos, but
it might have been the incipit.)  

    Mats> One solution is to add the property setting
    Mats> \property Score.barAlways=##t
    Mats> which allows Lilypond to insert line breaks between every 
    Mats> single note, not just at every four quavers.

I've thought about using that, and it does in fact fix this particular
problem.  But some of the people I play with used to complain when
abc2ps would break a line in the middle of a "beat" (in this case, a
half note), so I was thinking of the fact that lilypond puts in an
invisible bar every so often as a feature.  So if I did barAlways, I
would have to check this carefully, and that's the kind of thing
computers should do for you.

So I tried changing the line width to 400 pt instead of 390 with the
geometry package, and lilypond-book crashed on me:

lilypond-book (GNU LilyPond) 1.4.2
Reading `/tmp/test.lytex'
Reading `/tmp/'
Traceback (most recent call last):
  File "/usr/local/bin/lilypond-book", line 1270, in ?
  File "/usr/local/bin/lilypond-book", line 1185, in do_file
  File "/usr/local/bin/lilypond-book", line 649, in scan_preamble
  File "/usr/local/bin/lilypond-book", line 632, in scan_latex_preamble
    paperguru.set_geo_option(k, o[k])
  File "/usr/local/bin/lilypond-book", line 185, in set_geo_option
    self.m_geo_width =  value
  File "/usr/local/bin/lilypond-book", line 195, in __setattr__
    f = dimension_conversion_dict[dim]
NameError: There is no variable named 'dim'

Here's the lytex file that did that:

Attachment: test.lytex
Description: Text document

Laura (mailto:address@hidden , )
(617) 661-8097  fax: (801) 365-6574 
233 Broadway, Cambridge, MA 02139

reply via email to

[Prev in Thread] Current Thread [Next in Thread]