[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Again: Lilypond 1.3.140 compilation on SuSE 7.1

From: Amelie Zapf
Subject: Again: Lilypond 1.3.140 compilation on SuSE 7.1
Date: Fri, 23 Mar 2001 00:19:06 +0100

Hi folks,

after a lot of copying around & placing shell scripts etc. pp., Lily still does
not run on my system. It delivers error messages (with such as:

address@hidden:~/music/input/tutorial > ly2dvi
*** Temp directory is `/var/tmp/@1196.1ly2dvi'

Invoking `lilypond   -I /home/amelie/music/input/tutorial -H title -H subtitle 
-H subsubtitle -H footer -H head -H composer -H arranger -H instrument -H opus 
-H piece -H metre -H meter -H poet -H language -H linewidth -H latexpackages -H 
latexheaders -H orientation -H pagenumber -H textheight -H papersize 
/home/amelie/music/input/tutorial/menuet '
GNU LilyPond 1.3.140error: can't find file: `lily.scm' (load path: 
Fehler: Fehler: command exited with value 256
Traceback (most recent call last):
  File "/usr/local/bin/ly2dvi", line 537, in ?
    dvi_name = do_files (files, extra)
  File "/usr/local/bin/ly2dvi", line 435, in do_files
    run_lilypond (fs)
  File "/usr/local/bin/ly2dvi", line 271, in run_lilypond
    system ('lilypond  %s %s ' % (opts, fs))
  File "/usr/local/bin/ly2dvi", line 251, in system
    error (msg)
  File "/usr/local/bin/ly2dvi", line 115, in error
    raise _ ("Exiting ... ")
Exiting ...    

although the /scm directory with lily.scm is properly placed in

Joerg Anders turned my eyes to the bug in the
lilypond-1.3.140/mutopia/mutopia.make file. On a SuSE system, given that
installation is carried out in an arbitrary directory in the /home/[USERNAME]/
tree (only thing I've tried, as I didn't want to build an RPM at the moment),
compilation fails at the file stated above very late in the compilation
process. The error message is as follows:

make[1]: Entering directory 
../mutopia/mutopia.make:23: *** can't find LilyPond's stepmake installation.  
make[1]: Leaving directory 
make: *** [all] Error 2              

Enter the makefile /mutopia/mutopia.make. It reads

# mutopia/mutopia.make
# Magic: find and include LilyPond's StepMake rules
# 1: try source tree
# 2: try installed tree in $HOME
# 3: try system installed tree
make-root=$(wildcard $(LILYPONDPREFIX)/make)
make-root?=$(wildcard $(HOME)/usr/src/lilypond/make)
make-root?=$(wildcard /usr/share/lilypond/make)
make-root?=$(wildcard /usr/share/lilypond/make)
#make-root=<LilyPond's datadir>/make
ifneq ($(make-root),)
### some versions apparently choke on $(message)
### $(message running from $(make-root))
include $(make-root)/stepmake.make
$(error can't find LilyPond's stepmake installation)

I don't know what $(LILYPONDPREFIX) and $(HOME) point to, but I assume that
$(LILYPONDPREFIX) points to the directory where Lilypond is going to be
installed and $(HOME) points to the compiling user's home directory. Both are
not viable in that case (but please, I don't get the big picture here, I'm just
assuming). Thus, could another option be added, pointing to the directory from
which the "make" command was issued? Or, does the /make/stepmake.make file need
to have been pre-processed by something or the other? Anyway, the bug needs to
be worked out. I'm gonna try my very best, but, believe me, I have almost zero
experience with hand-writing makefiles. I'd be glad to receive any help. The
ifneq condition is the problem - let's find a solution!

So, after this long posting,

good night to y'all


reply via email to

[Prev in Thread] Current Thread [Next in Thread]