[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Debian patch for LilyPond 1.3.119

From: Anthony Fok
Subject: Re: Debian patch for LilyPond 1.3.119
Date: Sat, 23 Dec 2000 13:46:17 -0700
User-agent: Mutt/1.2.5i

On Sat, Dec 23, 2000 at 12:29:22PM +0100, Jan Nieuwenhuizen wrote:
> Anthony Fok <address@hidden> writes:
> > Anyhow, here is a new patch for 1.3.119.  Enjoy!
> Thanks, the package builds again.  Before, we had troubles with
> `dh_installchangelogs -k': can't use -k for native debian package or
> so.

... Oh, I see!  I was scratching my head about those additions in
debian/rules because "dh_installchangelogs -k" never gave me any problem,
nor did it complain when I built 1.3.119.  But, judging from the "cant use
-k for native debian package", I guess the culprit is in the
debian/changelog file:

Compare the two and see the difference:

        lilypond1.3 (1.3.119-1) unstable; urgency=low
        lilypond1.3 (1.3.107) unstable; urgency=low

Yes, the difference is "-1".  Next time, if you want to make a local build,
say for 1.3.120, make sure you use "1.3.120-0" or "1.3.120-1" instead of
"1.3.120" in debian/changelog.  Without the suffix number, dpkg would treat
it as a native package, and then dh_installchangelogs -k would fail.

> > BTW, I had to fix some stuff in development.itexi (?) so it would build
> > properly.  I am not sure if the way I fixed it was what you intended
> > though, so please double check before adding it to your source.
> Thanks!  We're always using --force, to be sure of a build, but the
> info pages may not be browsable when errors occur.

For some reasons, the --force wasn't there during the build, so it just
stopped there (and I had to restart the build). But when I ran make again,
without "make distclean", the --force was there and after some warning
messages it continues on merrily.  Strange. But then this computer I am
using is really acting up too... segfaulting and kernel oopsing/panicking
erratically that I simply couldn't finish the build without being stopped at
random places.  So I ended up using my brother's computer to build
lilypond1.3_1.3.119-1.  Besides, his computer is so much faster.  :-)

(My brother users Windows ME, but a while ago I "sneak-installed" Debian on
it so it can now dual-boot.  He wasn't too happy because I took about 1GB of
space from his D: drive.  He vowed to wipe out the entire hard drive to get
rid of the Debian partition, but he hasn't done it yet.  ;-)

> > BTW, to build the lilypond deb, make sure all the packages listed in
> > debian/control are installed.  And I won't suggest using "make deb"
> > in the GNUmakefiles.  Let's just use the tried-and-true method.
> Ha, but you fixed it, and it now does `dpkg-buildpackage -r fakeroot',
> which currently is the tried-and-true method, I guess?  I'm still a
> bit of a Debian distro newbe.

I hope it works.  I haven't tried it, but yes, I would say using fakeroot
is better than su in most cases because you do not really need to be root
when you use fakeroot.  Sometimes fakeroot does cause trouble, but not with

> > I usually just use the "debuild" command.
> Is that perchance
>     12:23:55 appel ~$ locate build | grep deb
>     /usr/bin/dh_builddeb
>     /usr/share/man/man1/dh_builddeb.1.gz
> Ah, or maybe
>     12:27:27 appel ~$ apt-cache search debuild
>     devscripts - Scripts to make the life of a Debian Package
>     maintainer easier
> but devscripts is currently not available, it seems.

Yes, it is here:

You probably heard that Debian just added a "testing" distribution:

     stable = potato
    testing = woody
   unstable = sid

A temporary side-effect of this addition is that woody is now
essentially the same as potato, where as sid is what woody was.
This will change soon, but for now, you may want to make sure you
point to "unstable" and not to "woody" in your /etc/apt/sources.list
if you were tracking unstable.  A few weeks later, you can change
"unstable" to "testing" if you prefer.

Oh, BTW, I made a typo in debian/changelog.  It should be bug #72223, not
#72233.  :-)  To see a list of bugs against lilypond 1.2.17 and
lilypond 1.3.x, see:

Especially, please check out #79064 and #79066 filed by Daniel Burrows.
How to solve them?  I don't have a clue, at least not yet.  :-)

Thanks, and cheers,


Anthony Fok Tung-Ling                Civil and Environmental Engineering
address@hidden, address@hidden    University of Alberta, Canada
   Debian GNU/Linux Chinese Project --
Come visit Our Lady of Victory Camp --

reply via email to

[Prev in Thread] Current Thread [Next in Thread]