[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compile-error

From: Pawel Kot
Subject: Re: compile-error
Date: Thu, 2 Nov 2006 14:41:01 +0100


On 11/2/06, Jari Turkia <address@hidden> wrote:
Pawel Kot wrote:
>> Running fgrep -l AM_GNU_GETTEXT *  in /usr/share/aclocal reveals that
>> the macro can be found in gettext.m4.
> So, you have gettext.m4 :)
Now I do. The required package was gettext-devel.

Most of my mistakes are FAQs anyway. Somebody should update wiki to
contain compile instructions.

You're welcome :)

> That should be in pkgconfig package in SuSE.

Good tip. That solved the configure-problem. Like I said earlier FC is
ok, but still on SuSE there is a glitch:
/bin/sh ../libtool --mode=compile gcc -g -O2 -Wall -Wno-pointer-sign
-fvisibility=hidden  -I../include  -INONE -o gnvcal.lo -c gnvcal.c
 gcc -g -O2 -Wall -Wno-pointer-sign -fvisibility=hidden -I../include
-INONE -c gnvcal.c  -fPIC -DPIC -o .libs/gnvcal.o
gcc: gnvcal.c: No such file or directory
gcc: no input files
gmake[1]: *** [gnvcal.lo] Error 1

Install flex. ;P

Since this thread started with Solaris compile problem, I tried my newly
learned trick about running ./ on a Solaris. Configure fails:
checking for ar... ar
./configure: AC_LIBTOOL_WIN32_DLL: not found
./configure: AC_PROG_LIBTOOL: not found
checking for a BSD compatible install... /opt/sfw/bin/ginstall -c
./configure: AC_RELOCATABLE: not found
./configure: AM_ICONV: not found
checking for libintl.h... yes
./configure: syntax error at line 1319: `AM_GNU_GETTEXT' unexpected

And I am running the configure with --disable-nls. The machine seems not
to have gettext and I have no permission to install one. Why is it
required if I'm running with no NLS anyway?

Well, NLS is not required. But you need to detect somehow that it is
not installed. I will add all required m4 files to gnokii local copy,
so it wouldn't be dependent on the system.

take care,
Pawel Kot

reply via email to

[Prev in Thread] Current Thread [Next in Thread]