[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

building dku2 Patch : make: No rule to build >>modules<<

From: Holger Neu
Subject: building dku2 Patch : make: No rule to build >>modules<<
Date: Thu, 06 Apr 2006 23:40:12 +0200

Im trying to connect my Nokia 6230i to my Linux System with a DKU2
I could compile and run gnokii 0.6.11 and tried to compile the patch for
the usage of the DKU2 cable. ./configure seems to work fine and creates
a Makefile for the patch. But runing make leads to the folowing message

patches/kernel_2.6> make
make[1]: Entering directory
make[1]: *** Keine Regel, um Ā»modulesĀ« zu erstellen.  Schluss.
make[1]: Leaving directory
make: *** [module] Fehler 2

message at make[1] means: ***No rule to create >>modules<<.  End

I checked the makefile (see below) and have to admitt that I also don't
know what modules stands for. I tried to execute configure with the 
./configure --with-kernsrcdir=dir1 --with-kernmoddir=dir2 
where dir1 & 2 where the default dirs and my individual dirs.

Below the Makefile generated by ./configure

----8<---- header above ------------------------------------------------
MODULE_NAME   := nokia_dku2
MODULE_ROOT   := /lib/modules/2.6.13-15.8-default/kernel/drivers/usb/serial

KERN_SOURCE   := /lib/modules/2.6.13-15.8-default/build
PWD           := $(shell pwd)

obj-m         := $(MODULE_NAME).o

all: module

        @$(MAKE) -C $(KERN_SOURCE) SUBDIRS=$(PWD) modules

        @rm -f .*.{cmd,flags}
        @rm -f $(MODULE_NAME).{o,ko,mod.{o,c}} built-in.o
        @rm -fr .tmp_versions

        if ! [ -f $(MODULE_OBJECT) ]; then \
        module; \
        install -m 744 -o 0 -g 0 $(MODULE_OBJECT) $(MODULE_ROOT)
        /sbin/depmod -a

------8<----end of makefile--------------------------------------

Im Runing Suse 10,0 on an Athlon 64 system as 64 Bit system
Kernel 2.6.13-15.8
identify returns:
address@hidden:~> gnokii --identify
GNOKII Version 0.6.11
Orphaned line: port = /dev/ttyUSB0
Orphaned line: model = 6230i
Orphaned line: initlength = default
Orphaned line: connection = dku2
Orphaned line: use_locking = yes
Orphaned line: serial_baudrate = 19200
Orphaned line: smsc_timeout = 10
LOG: debug mask is 0x1
Config error - no model specified.

If you need further information please let me know. I have no idea what
causes the problem compiling the patch. Any help wild be appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]