[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Backing up a Nokia 3595?

From: Dan Stromberg
Subject: Backing up a Nokia 3595?
Date: Sat, 20 Nov 2004 20:15:49 -0800
User-agent: Pan/0.14.2 (This is not a psychotic episode. It's a cleansing moment of clarity.)

The short version:

I'm trying to back up the phone list on a Nokia 3595, by pulling the
simcard out, popping it into a spare Nokia 8290, and then attempting to
back up the 8290 using Gnokii and a data cable.  However, the 8290 does
not seem to be able to powerup using the power from the USB cable.

Is there a way of doing something like this?  Just about anything that
would let me back up my 3595 would make me happy.  :)

This is the --=long=-- version.  It details just about everything I
tried to get this to work so far.  :)

Memo: 49, exported from J-Pilot on 11/20/04 08:06PM
Category: Unfiled
This memo was marked as: Not Private
----- Start of Memo -----
Backing up a Nokia 3595

I have a lot of phone numbers on my cell phone, some of which are -only-
on my cell phone.  So naturally, I want to be able to back it up.

After discussing this with some folks in the office, and doing some
googling, I concluded that an approach to take would be to remove my
simcard from my 3595, pop it into spare 8290 Lillian keeps, and the plug
the USB cable we got from into the 8290, and back up my
3595's simcard over the data cable.

When I first looked at the cable, I was disappointed, because it wouldn't
connect to the bottom of the 8290 like I expected.  A little fiddle
though, and popping out the 8290's battery, the data cable plugged right
into the back of the 8290.

Next I started building the "gnokii" software on a Fedora Core 3 system,
said software purporting to be able to communicate with some (not all -
like not my 3595) Nokia phones over a data cable, or over infrafred.
The build was straightforward, though long.

As a nice bonus, gnokii claims to be able to dial using the phone via
a number entered on your computer, add ringtones, send SMS messages,
and so on.

gnokii apparently also runs on windows.  And the data cable came with
a mini CD with w98, w/me, w2000 and w/xp software.

Finally gnokii finished building.  Then I tried running a few things
without reading the manual; no joy.  :)  So I fished up a manual page
(still in the source tree).

It became apparent that I needed: gnokii --getphonebook SM

...and that I would need a ~/.gnokiirc, which can be copied from
Docs/samples/gnokiirc initially.

Next I created a ttyUSB0 device: mknod /etc/udev/devices/ttyUSB0 c 188
0 chown strombrg /etc/udev/devices/ttyUSB0

...and put that in my gnokiirc.  BTW, that isn't the official way of
doing udev devices, but it works.  :)

...also had to specify the model of phone in ~/.gnokiirc.

Left ~/.gnokiirc using "serial", since the USB device I'm trying pretends
to be the usual serial device, like in the old days. :)

I'm going to try skipping setting bindir initially, since I put the
binaries in my homedir, and would prefer to avoid making anything
setuid root.

I'm turning on debug and rlpdebug, but not xdebug, at least initially.

Next I tried: tesuji-strombrg> gnokii --getphonebook SM 0 end GNOKII
Version 0.6.4 LOG: debug mask is 0x1 LOG: rlpdebug mask is 0x1 Please
check permission on lock directory.  Lock file error. Exiting. I decided to turn off locking in ~/.gnokiirc.

That looked better, but now I'm getting "failed to initialize interface".

strace didn't turn up much - just looks like the phone isn't answering.

At this point, I pulled open my 3595, and looked to see if it had the
connector this cable could use, even though I'd heard it wouldn't.  :)
It didn't.  :)

Next I decided to try seeing if I needed to turn on the 8290.  :)  It
wouldn't power up on the USB cable.  So I pulled off the USB cable,
and put the battery back in.  Then the phone powered up, but told me
that it didn't have a simcard!  :)

Obviously, it was time to put my 3595's simcard into the 8290.  :)

So I did.  And I found that the phone still wouldn't power up, in the
way that worked with the battery in it, at least.

Time to try gnokii again: gnokii --getphonebook SM 0 end

Just noticed that the serial speed being used isn't that in the
~/.gnokiirc, but that's probably a nonissue.

Next it was time to try to bring up the 8290 on its own battery, using
my 3595's simcard...  Survey says: It's powering up, initially says
"simcard not ready", but eventually allows my to view my phone list.
That's a semigood sign - it groks my simcard, but it doesn't seem to be
able to get power from the USB cable, the way a palm pilot would.

The cheap cable... the top fell off, but I'm assuming it's still
electrically sound.

Next I inspected the cable to see if there was some sort of on/off switch.
:)  But there doesn't appear to be any.

What the heck?  Let's run my gnokii command as root, just in case
there's some weird permissions problem that didn't show up in the strace.
And... No joy. Same errors as when I run it as myself.

Erie: just discovered that I had the wrong model of phone in
~/.gnokiirc. Hm.  Anyway, time to try the gnokii command again!  :)

Same result, and the model number in ~/.gnokiirc didn't change.

Time to check the doc for occurences of 8290.  Oddly enough, it turns out
the 8290 is part of the 6110 line, and I believe that may have been the
"strange" model number I saw in ~/.gnokiirc. Hm again.

Time to try xgnokii.  :)  Pretty fancy little app.  Looks kind of like
a media player application.  It's not promising that the "battery"
and "signal" lights are red though.  I tried clicking those lights,
but nothing happened.  I also tried mousing around a bit, left, middle,
right buttons, but got nowhere.

The FAQ has something about a --keysequence option and a "P" argument to
it that is supposed to mean "power".  This sounds promising, but if I run:

gnokii --keysequence P

...then I just get that huge usage message again.  :-S

Running mgnokiidev does don't anything useful (yet).

Running gnokiid gives a familiar series of messages - nothing new here.

gnokii --identify doesn't really do anything useful either, AFAIK.

Just saw the "lsusb [-v]" command for the first time.  Cool.  :)

Just saw a message saying that gnokii is good with GSM, not so good
with CDMA.  Not sure which we have though!  :)

gnokii --monitor didn't do anything different really.

Turns out you can use "model = auto" in ~/.gnokiirc, and someone go this
to work with an 8290.  :)

model = auto just got me: Sorry, phone has not yet been converted to
new style. Phone.Functions == NULL!

Just found the above error in the FAQ.  It claims it means I'm using
an ancient version of gnokii.  However, I'm using the latest version of
the main download site, and a version newer than on a mirror I checked.

Time to try gnocky, another X interface.  :)  It has a disturbingly low
version number, but...  maybe it's worth a try.  :)

Pfaugh. gnocky wants a gnokii -rpm-.  Never mind.

Hm. Just discovered that my USB palm sync'ing isn't working either.
Might be time for a reboot.  But not today!

OK, one more thing for tonight: I unloaded and reloaded a bunch of kernel
modules as required to get my palm to sync again, and -then- tried again
to get gnokii to talk to the 8290.  No dice.  Palm works, 8290 doesn't.

I'm heading home!

Interesting!  Using gnokii appears to have messed up my palm sync!

OK, really am leaving now, -without- one last palm sync.  :)

----- End of Memo -----

reply via email to

[Prev in Thread] Current Thread [Next in Thread]