[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

nokia 3589i connection problems

From: Dan Lenski
Subject: nokia 3589i connection problems
Date: Tue, 27 Jan 2004 21:00:21 -0500

I just got a Nokia 3589i phone (US model), and I'm trying to get it
working with my linux box.  My priority is to use it as a modem, but I
would also like to be able to use it with gnokii.

I got a no-name USB-to-phone serial cable on eBay.  The package claims
it uses a prolific 2303 chip.  It is recognized as a pl2303
usb-to-serial adapter, according to the syslog:

Jan 27 20:22:11 localhost kernel: drivers/usb/serial/usb-serial.c:
usb_serial_probe - setting up 1 port structures for this device
Jan 27 20:22:11 localhost kernel: drivers/usb/serial/usb-serial.c:
usb_serial_probe - registering ttyUSB0
Jan 27 20:22:11 localhost kernel: usb 1-1: PL-2303 converter now
attached to ttyUSB0 (or usb/tts/0 for devfs)

The problem is that I can't communicate with the phone.  I've tried
using minicom to send modem commands directly to /dev/ttyUSB0, but this
doesn't do anything.  I've also tried gnokii, the linux Nokia phone
manager program.  I know that the 3589i is not explicitly supported, but
I tried AT mode as well as a number of others, with no luck.  The phone
doesn't even display anything special.

Can anyone give me any advice?  Is this a problem with my phone, my
cable, or the software?  Should I be using a different cable?  I would
get an official Nokia DKU-5 cable, but I heard they're not supported
under linux.  Any help is greatly appreciated!

Dan Lenski

reply via email to

[Prev in Thread] Current Thread [Next in Thread]