[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem compiling gnokii on sparc

From: Alexandre Suter
Subject: Re: problem compiling gnokii on sparc
Date: Thu, 22 Jan 2004 01:10:56 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031210

Actually, I just found out that the new gnokii 0.5.9 compiles like a charm. So my problem (getting gnokii to work on my sunblade) is solved. Thank you for this wonderful piece of software, anyway !



Alexandre Suter wrote:


I've been trying desperately to get gnokii compiled on my sunblade 100. It's a gentoo system with gcc 3.2.3 and ld I've been trying to compile gnokii-0.5.8 and a few older versions as well, each time I get to the same error:

gmake -C common/phones
gmake[1]: Entering directory `/root/software/gnokii-0.5.8/common/phones'
gcc -g -O2  -I../../include   -c -o generic.o generic.c
gcc -g -O2  -I../../include   -c -o nokia.o nokia.c
gcc -g -O2  -I../../include   -c -o nk7110.o nk7110.c
gcc -g -O2  -I../../include   -c -o nk6510.o nk6510.c
gcc -g -O2  -I../../include   -c -o nk6160.o nk6160.c
gcc -g -O2  -I../../include   -c -o nk6100.o nk6100.c
gcc -g -O2  -I../../include   -c -o nk3110.o nk3110.c
gcc -g -O2  -I../../include   -c -o atgen.o atgen.c
gcc -g -O2  -I../../include   -c -o atbosch.o atbosch.c
gcc -g -O2  -I../../include   -c -o ateric.o ateric.c
gcc -g -O2  -I../../include   -c -o atnok.o atnok.c
gcc -g -O2  -I../../include   -c -o atsie.o atsie.c
gcc -g -O2  -I../../include   -c -o fake.o fake.c
gcc -Xlinker -r -nostdlib -nodefaultlibs -o PHONES.o generic.o nokia.o nk7110.o nk6510.o nk6160.o nk6100.o nk3110.o
atgen.o atbosch.o ateric.o atnok.o atsie.o fake.o
/usr/lib/gcc-lib/sparc-unknown-linux-gnu/3.2.3/../../../../sparc-unknown-linux-gnu/bin/ld: --relax and -r may not be used together
collect2: ld returned 1 exit status
gmake[1]: *** [PHONES.o] Error 1
gmake[1]: Leaving directory `/root/software/gnokii-0.5.8/common/phones'
gmake: *** [common/phones] Error 2

I've searched the list and the web, and couldn't find a solution to my problem, barely an explanation here:

does anybody have an idea how to solve the problem ? as the above link relates to gnokii 0.4.3, I suppose this problem has been here for a while already...

best regards,

Alexandre Suter

gnokii-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]