[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnewsense-dev] Has anyone tried xorg-server-1.5.3 yet?

From: Zhang Le
Subject: [Gnewsense-dev] Has anyone tried xorg-server-1.5.3 yet?
Date: Tue, 17 Feb 2009 02:31:08 +0800
User-agent: Mutt/1.5.16 (2007-06-09)

I am trying to make it work.
The current status is: after startx, the screen is white, nothing shows, no
mouse, no window. Then the color changed. Left half still white, a pink stripe
in the middle, a grey area in the right.
But the system is still working. X could be killed.

I am using xorg-server-1.5.3 with this patch:;a=blob;f=x11-base/xorg-server/files/xorg-server-1.5.3-loongson.patch;h=9c48b3752b7f14b6603524f46ae832f312e7c6fe;hb=HEAD

I am using latest linux-mips source with latest lemote linux source:;a=summary

xorg-server 1.5.x requires linux has this patch:;a=commit;h=98873f53becea9a8a46972ff252e96fe575b120d
which mean at least linux-2.6.28. Lemote's linux version is only 2.6.27:;a=summary
So I have merged lemote's linux git tree with linux-mips's. The source can be
found in above the above link.

This combination of xorg-server and linux is working on fuloong 2f box.

So I guess the problem should be in xf86-video-siliconmotion driver.
Liu Shiwei of told me the latest source is here:
Is it?

Thanks in advance!

Zhang, Le

reply via email to

[Prev in Thread] Current Thread [Next in Thread]