[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash] Re: compile failure on amd64 with latest cvs

From: Tristan Wibberley
Subject: [Gnash] Re: compile failure on amd64 with latest cvs
Date: Mon, 09 Oct 2006 16:59:19 +0100

On Mon, 2006-10-09 at 17:25 +0200, strk wrote:
> On Mon, Oct 09, 2006 at 01:29:02PM +0100, Tristan Wibberley wrote:
> > /usr/bin/ld: /usr/lib64/libagg.a(agg_vcgen_stroke.o): relocation
> > R_X86_64_32S against `a local symbol' can not be used when making a
> > shared object; recompile with -fPIC
> > /usr/lib64/libagg.a: could not read symbols: Bad value
> Did you try adding -fPIC to your CXXFLAGS ?

I tried adding it to AM_CPPFLAGS and rerunning

./autogen && ./configure && make clean && \
make && sudo make install

but now I realise that was plain stupid and have retried with the environment 
variable CXXFLAGS set.
The same problem happens; could it be agg at fault?


Still not my employer's opinion.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]