[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Geiser-users] geiser-xref-callers does not seem to work

From: Jose A. Ortega Ruiz
Subject: Re: [Geiser-users] geiser-xref-callers does not seem to work
Date: Sat, 27 Jan 2018 17:41:41 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.91 (gnu/linux)

On Mon, Dec 18 2017, Andy Wingo wrote:

> On Sat 16 Dec 2017 08:55, Chris Marusich <address@hidden> writes:
>> * Place point on symbol expression->derivation-in-linux-vm on line 203
>>   (in the definition of the iso9660-image procedure), and press "C-c <".
>> When I do this, I receive the following message in the minibuffer:
>>   No callers found for ’expression->derivation-in-linux-vm’
>> And yet, if I run "M-x rgrep" on the same symbol, there are obviously
>> many call sites:
>>   ./gnu/system/vm.scm:68:  #:export (expression->derivation-in-linux-vm
>>   ./gnu/system/vm.scm:105:(define* (expression->derivation-in-linux-vm name 
>> exp
>>   ./gnu/system/vm.scm:203:  (expression->derivation-in-linux-vm
>>   ./gnu/system/vm.scm:274:  (expression->derivation-in-linux-vm
>> What might the problem be?  When I run "M-x geiser-doc-symbol-at-point"
>> on this symbol, it also claims that there is no documentation
>> available.  I feel like maybe I've misconfigured something, but I don't
>> know what.
> It appears to be a Geiser problem and not a Guile problem:

hmmm, i was investigating this.  the cause geiser fails is that, in the
process of looking for other things, it's not able to find
`program-arities', exported by (system vm program).  i am not sure why:

~$ guile
GNU Guile 2.2.3
Copyright (C) 1995-2017 Free Software Foundation, Inc.

Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
This program is free software, and you are welcome to redistribute it
under certain conditions; type `,show c' for details.

Enter `,help' for help.
scheme@(guile-user)> (use-modules (system vm program))
scheme@(guile-user)> program-arity
$1 = #<procedure program-arity (prog ip)>
scheme@(guile-user)> program-arities
ERROR: Unbound variable: program-arities

Entering a new prompt.  Type `,bt' for a backtrace or `,q' to continue.
scheme@(guile-user) [1]> 

Any idea what might be wrong?

Have a place for everything and keep the thing somewhere else; this is
not advice, it is merely custom.  -- Mark Twain

reply via email to

[Prev in Thread] Current Thread [Next in Thread]