[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Geiser-users] Feature request: preserve point in geiser-set-scheme

From: Christopher Howard
Subject: Re: [Geiser-users] Feature request: preserve point in geiser-set-scheme
Date: Tue, 21 Nov 2017 16:20:41 -0900

Hi, I'm still getting the same behavior after trying a few different

- I installed commit c3bc099.
- I tried other schemes when running geiser-set-scheme
- I tried running emacs with -nw -q and running (require 'geiser-
install) manually, to avoid complications from my .emacs file.
- I tried creating a new file and putting a few toy expressions in it,
but no actual define statements.

I all cases, running geiser-set-scheme jumps to just after the first
parenthesis of the last top-level expression.

I am quite curious what would happen if I switched to emacs-25, but I
wasn't sure if it was worth it to me to go to the trouble of compiling
and installing a whole new version of emacs. What emacs are you

On Tue, 2017-11-21 at 21:23 +0100, Jose A. Ortega Ruiz wrote:
> Hi Christopher,
> On Tue, Nov 21 2017, Christopher Howard wrote:
> > Hi, I am running geiser 0.9 with emacs 24.5.1. When I run geiser-
> > set-
> > scheme, point unnecessarily jumps to the beginning of the last
> > function
> > in my file. Can that be adjusted to return point back to where I
> > was
> > typing before running the command?
> I'm in geiser's "unstable" version (from melpa or directly the
> savannah
> git repo) and cannot observe that behaviour: point remains where it
> is.
> Any chance you could try with a newer geiser?  Maybe it happens only
> when switching to a particular scheme implementation?
> Cheers,
> jao

Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]