[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gcmd-usr] glib version too low

From: Ken Taylor
Subject: Re: [gcmd-usr] glib version too low
Date: Sat, 12 Feb 2022 13:21:10 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Friday, February 11, 2022 10:19 PM, Peter Horsley 
<peter.g.horsley@gmail.com> wrote:

> Hello,
> Trying to configure gnome-commander-1.14.0 on a fresh install of ZorinOS
> (based on Ubuntu 20.04) and i'm getting this error running ./configure:
> configure: error: Package requirements (glib-2.0 >= 2.66.0) were not met:
> Requested 'glib-2.0 >= 2.66.0' but version of GLib is 2.64.6
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
> Alternatively, you may set the environment variables GLIB_CFLAGS
> and GLIB_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> When I try to run sudo apt upgrade libglib2.0-dev I get:
> libglib2.0-dev is already the newest version (2.64.6-1~ubuntu20.04.4)
> Can anyone tell me how to update my version of this package to at least the
> minimum required to configure gnome-commander?
> cat /proc/version gives
> Linux version 5.13.0-28-generic (buildd@lgw01-amd64-035) (gcc (Ubuntu
> 9.3.0-17ubuntu1~20.04) 9.3.0, GNU ld (GNU Binutils for Ubuntu) 2.34)
> #31~20.04.1-Ubuntu SMP Wed Jan 19 14:08:10 UTC 2022
> Thanks for your time.
> Peter
> gcmd-users mailing list
> gcmd-users@nongnu.org
> https://lists.nongnu.org/mailman/listinfo/gcmd-users

Hello Peter,

I experienced the same thing on Linux Mint 20.3 which is based on Ubuntu 20.04 
ESR. The latest gnome-commander builds fine on Ubuntu 21.10 and per another 
post to this list will work on the Ubuntu 22.04 pre-release. I do not know of a 
way to update glib-2 on the 20.04 releases and I suspect that if it was updated 
it would break something else. I have accepted the fact that I will have to 
wait a couple of months for Ubuntu 22.04 LTS to be released and then for Mint 
to release their upgrade :-(


reply via email to

[Prev in Thread] Current Thread [Next in Thread]