[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gcmd-usr] A rather strange g-c experience

From: kht-lists
Subject: [gcmd-usr] A rather strange g-c experience
Date: Tue, 08 Jan 2019 14:14:41 +0000

Hello all,

I do not think I can call this a bug and I am not sure I can reproduce it. (I 
hope not as I had to shut down two virtual machines, un-mount 3 encrypted 
partitions, shut down  Linux, hard shut down my computer as it would not shut 
down, restart the computer, unlock and mount the encrypted partitions, restart 
the VMs etc.)

I am running CentOS 7.6 on a Dell Precision 3620 workstation. I am using the 
Mate desktop and g-c 1.8.1. My task was to copy about 5,000 mp3 files to a 32 
GB USB 2 flash drive. This represents my 450+ CD music collection. The flash 
drive was intended to be used with a Raspberry Pi as a jukebox for my workshop. 
 I formatted the flash drive as fat32 and copied the files using g-c. No 
problem other than it took a LONG time. I then planned to set the immutable 
attribute on the files on the flash drive so that I could not accidentally 
delete any. This is how I have my current juke box, an old laptop, setup. Of 
course I cannot set attributes on fat32 :-(

I then formatted the flash drive as ext4. Naturally the journal feature of ext4 
took up just enough space that the files would not fit.  It then occurred to me 
that I could simply mount the flash drive in the Pi as read only. I again 
formatted the flash drive as fat32 and copied the mp3 files to it. This time I 
used caja (nautilus) as it gives a time remaining guesstimate. A couple of 
hours later the deed was done.

I attempted to access the mounted flash drive with g-c in order to do some 
manipulation and sorting of the files. I clicked on the mount point 
/run/media/ken/music/.  g-c could not access the flash drive. The little 
spinner spun and spun and eventually I had to force quit. I tried unmounting 
and remounting, unmounting removing and reinserting the drive. I could access 
the drive with caja and from a bash terminal. I reformatted the drive, tried 
different file systems, logged out and back in to CentOS, checked the file 
system on the flash drive, everything I could think of short of a reboot. Then 
I attempted to shut down. The monitors went blank but the power light on the 
machine never went out. I finally had to hard power it off.

The machine is back up now, I have mounted the flash drive and am copying the 
files to it using g-c. Obviously this experience was some sort of OS or 
hardware related issue. I find it curious that g-c observed some sort of issue 
with the flash drive and would not access it whereas caja and the terminal 
would.  Has anyone else had any similar anomalies? Just curious.


Sent with [ProtonMail](https://protonmail.com) Secure Email.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]