[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gcmd-usr] a few 'make' errors

From: Uwe Scholz
Subject: Re: [gcmd-usr] a few 'make' errors
Date: Sat, 19 May 2018 14:28:53 +0200

Am Fri, 18 May 2018 23:30:27 -0500 schrieb address@hidden:
> On 05/18/2018 04:52 PM, Uwe Scholz wrote:
> > Wow, this is pretty new to my. I googled a bit and found out that
> > this seems to be related to itstool:
> >
> > http://guix-devel.gnu.narkive.com/l8HiwDvg/01-01-gnu-itstool-update-to-2-0-4
> >
> > https://github.com/itstool/itstool/issues/17
> >
> > Which version of itstool are you using?
> >
> > On Travis, the automated continuous integration system connected to
> > GitHub, they are using version 2.0.2 of it and there it is working.
> > See for example the last build log from March 14th here:
> > https://travis-ci.org/gcmd/gnome-commander/builds/353551012?utm_source=github_status&utm_medium=notification
> > (See lines 2635 and 3614)
> >
> > It could be worth to check for the itstool version you are using and
> > maybe update/downgrade it.
> >
> > [...]
> Uwe,
> Thanks for the links.  Maybe you or someone can help me sort thru
> this a little deeper.
> I read what itstool does, but as you'll see, I'm not sure it's even 
> installed (correctly).
> SHORT VERSION: I have no idea which installed packages require
> itstool - at all, or v2.0.4.  Efforts to find that data mostly failed.
> I also have no idea why some itstool files are on my system or have
> any recollection of saving a tar package in ~/Downloads/...
> I also looked under Synaptic manual installed packages - nothing
> there. If the tar package was built & installed, another app did it,
> not me.
> "ITS Tool allows you to translate your XML documents with PO files, 
> using rules from the W3C Internationalization Tag Set (ITS) 
> <http://www.w3.org/TR/its/> to determine what to translate and how to 
> separate it into PO file messages."

Correct, itstool is used for creating translated xml files at the end
of the make process. I don't know the internals of this program, but
comparing the output from your first mail with the issue reported on
GitHub it seems as you definitely run into the bug of itstool 2.0.4.

> > Which version of itstool are you using?
> Maybe none that are "installed," but a copy of the itstool file is in 
> /usr/local/bin; apparently 2.0.4.
> Synaptic doesn't show itstool as installed (not thru Mint's repo or
> any added PPA).
> But the file, "itstool" is located in /usr/local/bin/itstool, so
> another app update may have installed it (or attempted) or I did &
> forgot.
> I see the package in my home 
> ~/Downloads/utilities/file-utilities/general/itstool-2.0.4.tar.bz2, 
> indicating I downloaded it (why??), but I'm sure I never did the
> build process.

Okay, this is really strange. Certainly someone must have downloaded
this tool sometime in the past on your computer. You could find out at
least when this happened by inspecting the creation date of the tar.bz2
package in the folder above. And maybe find out the owner of this file.

> When I run: /usr/local/bin $ itstool --version, I get:
> itstool 2.0.4  [version may only be reported, because a copy of the 
> itstool FILE is in a directory, but wasn't properly installed]
> I have no idea why the file would just be copied there (not
> installed). I don't think I did it.

As version 2.0.4 definitely has a bug which prevents Gcmd from being
installed, I would remove it from your system. A clean way in doing
this would be to extract the tar.bz2 package in a folder of your choice
(or better downloading the package again from a trusted source:
http://files.itstool.org/itstool/itstool-2.0.4.tar.bz2). Then unpack it
an run "./autogen.sh && sudo make uninstall". This should remove the
installed file from /usr/local/bin.

Afterwards, install the official Ubuntu package using synaptic.

> Now, about conflicting info.
> I ran a reverse dependency on itstool:
> $ apt-cache rdepends itstool
> itstool
> Reverse Depends:
>    ubuntu-gnome-desktop
>    yelp-tools
>    ubuntu-gnome-desktop
>    yelp-tools
> It seems to say the only packages (installed?) with a dependency on 
> itstool, are ubuntu-gnome-desktop and yelp-tools.  Yelp-tools is not 
> installed.  I don't know if the reverse dependency command is 100% 
> accurate (finds every package that's dependent on itstool).
> HOWEVER, "yelp-tools" isn't installed either, per Synaptic.

Yelp is the help browser from Gnome in which you can read the
(translated) help pages of various gnome program. I think the reason
why "apt-cache rdepends itstool" shows you this dependency is that it
also shows dependencies from uninstalled packages. But this is just my

> Also ran a *simulation* to see what would be removed *IF* itstool was 
> purged:
> $ aptitude -s purge itstool
> Package itstool is not installed, so it will not be purged
> Package itstool is not installed, so it will not be purged [either 
> RainMan (aka Dustin Hoffman) wrote the code for aptitude purge
> output, or it just likes to repeat certain lines.]
> The following packages will be REMOVED:
>    libguess1{u} libllvm4.0{u} libllvm4.0:i386{u} libmediaart-2.0-0{u} 
> libqcustomplot1.3{u}
>    libqt5scintilla2-12v5{u} libqt5scintilla2-l10n{u} libsdl2-2.0-0{u} 
> libsndio6.1{u}
>    libtracker-sparql-1.0-0{u} libwine-development{u} 
> libwine-development:i386{u}
>    ocl-icd-libopencl1:i386{u} python-distutils-extra{u} 
> python-twodict{u} tcllib{u}
> 0 packages upgraded, 0 newly installed, 16 to remove and 22 not
> upgraded. ************
> That's a bunch of stuff to remove, given that the site 
> http://www.linuxfromscratch.org/blfs/view/svn/pst/itstool.html, says 
> itstool's (2.0.4) only dependency is docbook-xml-4.5.
> Note, like Synaptic, it says itstool package is NOT "installed."
> I don't fully understand why the several other packages from the 
> aptitude PURGE command will be "REMOVED."
> Is it saying they'll be removed because they're supposedly
> dependencies of the itstool package, IF... it was installed
> correctly?  I can't find any evidence that any of them are itstool
> dependencies.

Suggestion: Aptitude wants to remove packages from you system which are
not required anymore at all. The above summary has nothing to do with
purging itstool alone I would say.

> I looked at most of the above packages that aptitude would remove. In 
> Synaptic, NONE of them were shown as dependencies of itstool, or vice
> versa.

This would fit in the picture that these packages are not needed
anymore on your system.

> But the next path & files were created - by something (not me), which 
> look to be associated w/ Wine (a Wine icon beside each file):
> /usr/local/share/itstool/its/docbook.its
> /usr/local/share/itstool/its/docbook5.its
> /usr/local/share/itstool/its/its.its
> /usr/local/share/itstool/its/mallard.its
> /usr/local/share/itstool/its/ttml.its
> /usr/local/share/itstool/its/xhtml.its

Someone must have created these files on your system. Either it was you
but you can't remember anymore or it must have been a process you or
another user of you computer has started. Regardless of who did it in
the end: Try to remove the current version of itstool (which must have
been installed via the sources on your system I believe) and install
the official Ubuntu package. Then you should be fine and the
installation of Gnome Commander should work like a charm.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]