[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gcmd-usr] Fedora 25: samba not working

From: Uwe Scholz
Subject: Re: [gcmd-usr] Fedora 25: samba not working
Date: Fri, 18 Aug 2017 15:28:30 +0200

Hi Thomas,

sorry for my late reply on this, I was absent in the meantime.

Am Sat, 15 Jul 2017 15:12:19 +0200 schrieb Thomas Kluth:

> Hi Uwe,
> > 
> > But: I don't have Samba installed locally and I don't have another
> > workstation with Samba running. This might be the cause of the error
> > message I see. I tried to install Samba with the help given here:
> > https://fedoraproject.org/wiki/Administration_Guide_Draft/Samba
> > 
> > I could manage to see my locally shared directory via
> > "smbclient -L", but I can neither open it in Gcmd NOR in
> > Thunar (under XFCE, typing "smb://localhost" in the address bar).
> > 
> > Thomas, if you could tell me how to setup Samba locally we might
> > find out there the problem with Gnome Commander hides.  
> I (or actually my brother who would like to use Gcmd) only connect(s)
> to external samba shares. To debug, I sucessfully enabled a Samba
> server on my Fedora 25 PC (runnig GNOME) doing the following:
> sudo dnf install samba samba-client
> ## samba user and password is different frum unix user / password --
> set it explicitly:
> sudo smbpasswd -a thomas
> # create samba share
> cd
> mkdir samba-test-share
> # let SELinux not deny permissions
> chcon -R -t samba_share_t samba-test-share/
> # add the following lines to /etc/samba/smb.conf:
> [testshare]
>       path=/home/thomas/samba-test-share
>       guest ok = yes
>       read only = no
> # restart samba:
> sudo systemctl restart smb
> After this, I could access (and write to) this testshare using Files
> aka nautilus, and also thunar by going to the address
> "smb://localhost/testshare". It did not work with Gcmd.
> Only typing smb://localhost somehow didn't work that well in neither
> file manager.
> Hope this helps.

Thank you for this well written summary! I set up my own Samba service
now, and I see the same result here: A window pops up saying that
there is an internal error occurring. Having a look at the sources at
the same time it looks like gnome-vfs cannot get a connection to the
Samba server.

Then, I checked the logs of my system and I found that error message
popping up at the same time when I tried to connect via GnomeCommander:

Aug 18 15:18:56 localhost.localdomain gnome-vfs-daemo[1457]: Cannot
load module
undefined symbol: smbc_remove_unused_server)

So it seems as if the problem is gnome-vfs. I'm not totally sure about
it, but it is a guess. This is all I could find for the moment about
it: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=542216

So it seems as there is currently no real solution for this problem :(

> Best,
> Thomas


reply via email to

[Prev in Thread] Current Thread [Next in Thread]