[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gcmd-usr] Failed to build 1.2.3

From: Mikhail Ramendik
Subject: [gcmd-usr] Failed to build 1.2.3
Date: Wed, 28 Feb 2007 19:25:35 +0000
User-agent: KMail/1.9.1


I am using Debian sarge. I have tried to backport gnome-commander 1.2.3 and 
the build dfailed. To get an acceptable report, I tried building 
gnome-commander 1.2.3 "locally" without package management, and got the same 

Here is the tail of the output of make:

if gcc -DHAVE_CONFIG_H -I. -I. -I..  -Wall -I.. -DORBIT2=1 -pthread -DXTHREADS 
-            I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0 
-I/usr/include/libgnome            canvas-2.0 -I/usr/include/gtk-2.0 
-I/usr/include/libart-2.0 -I/usr/include/gconf            /2 
-I/usr/include/libbonoboui-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/in   
clude -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 
-I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include 
-I/usr/include/bonobo-activation-2.0 -I/usr/include/pango-1.0 
-I/usr/include/freetype2 -I/usr/lib/gtk-2.0/include -I/u            
sr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/libxml2   -pthread 
-DORBIT2=1 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include 
-I/usr/includ            e/bonobo-activation-2.0 -I/usr/include/libbonobo-2.0 
-I/usr/include/gconf/2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include 
-I/usr/include/orbit-2.0   -DPLU            
GIN_DIR=\""/usr/local/lib/gnome-commander/plugins"\"   -g -O2 -MT 
gnome-cmd-advr            ename-dialog.o -MD -MP -MF 
".deps/gnome-cmd-advrename-dialog.Tpo" -c -o gnome-cm            
d-advrename-dialog.o gnome-cmd-advrename-dialog.c; \
then mv -f ".deps/gnome-cmd-advrename-dialog.Tpo" 
".deps/gnome-cmd-advrename-dialog.Po"; else rm -f 
".deps/gnome-cmd-advrename-dialog.Tpo"; exit 1; fi
gnome-cmd-advrename-dialog.c: In function `create_placeholder_menu':
gnome-cmd-advrename-dialog.c:359: warning: implicit declaration of function 
gnome-cmd-advrename-dialog.c:359: error: syntax error before 
make[3]: *** [gnome-cmd-advrename-dialog.o] Error 1
make[3]: Leaving directory `/home/misha/source/gnome-commander-1.2.3/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/misha/source/gnome-commander-1.2.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/misha/source/gnome-commander-1.2.3'
make: *** [all] Error 2

The version of libgtk-2.0 is 2.6.4 , the -dev package matches. Does 
gnome-commander 1.2.3 require a later gtk?

Yours, Mikhail Ramendik

reply via email to

[Prev in Thread] Current Thread [Next in Thread]