[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gcmd-dev] [gcmd-usr] Release of Gnome Commander 1.10.1

From: kht-lists
Subject: Re: [gcmd-dev] [gcmd-usr] Release of Gnome Commander 1.10.1
Date: Sun, 12 May 2019 18:56:47 +0000

Thanks again Uwe,

That almost did the trick.  I ran into the following error:

File not found: 

The file is now gnome-commander.svg so I changed line 156 in the spec file:

%{_datadir}/pixmaps/%{name}.png to .svg and the compile completed.

I copied the .rpm file to another machine and attempted to install it over g-c 

address@hidden Desktop]# yum localinstall 
Loaded plugins: fastestmirror, priorities
Examining gnome-commander-1.10.1-1.el7.x86_64.rpm: 
gnome-commander-1.10.1-1.el7.x86_64.rpm: does not update installed package.
Nothing to do

That was strange so I manually removed g-c 1.8.1 and tried my rpm again. It 
seems to have installed OK. However,

address@hidden Desktop]# gnome-commander

(gnome-commander:11051): GnomeUI-WARNING **: 14:27:44.735: While connecting to 
session manager:
None of the authentication protocols specified are supported.

(gnome-commander:11051): GLib-GIO-ERROR **: 14:27:44.749: Settings schema 
'org.gnome.gnome-commander.preferences.general' does not contain a key named 
Trace/breakpoint trap (core dumped)

I also noted that my rpm was a LOT larger than the rpm for 1.8.1 from the 
nux-dextop repo

 Package              Arch        Version                 Repository       Size
 gnome-commander      x86_64      4:1.8.1-3.el7.nux       nux-dextop      6.2 M

 Package       Arch   Version        Repository                            Size
 gnome-commander      x86_64      2:1.10.1-1.el7 
/gnome-commander-1.10.1-1.el7.x86_64  17 M

As a final trick I decided to install the rpm on my development virtual machine 
(the make install version works fine there). I have no idea how to "make 
uninstall" so I tried a reinstall with yum.

address@hidden x86_64]$ sudo yum reinstall 
[sudo] password for ken:
Loaded plugins: fastestmirror, langpacks, priorities
Examining gnome-commander-1.10.1-1.el7.x86_64.rpm: 
No package matched to remove: gnome-commander-2:1.10.1-1.el7
Error: Problem in reinstall: no package matched to remove

I am making progress - at least I keep reminding myself of that :-)


p.s. When I get this process working I will write up my notes and provide them 
to you. Perhaps you can post them along with the source code for CentOS, RHEL 
and Scientific Linux users (until the fellow at nux-dextop has time to add the 
latest g-c to his repo.)

Sent with ProtonMail Secure Email.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Sunday, May 12, 2019 1:15 PM, Uwe Scholz <address@hidden> wrote:

> Hi Ken,
> Am Sun, 12 May 2019 15:50:43 +0000 schrieb kht-lists:
> > Hello Uwe,
> > [...]
> >
> > RPM build errors:
> > Bad exit status from /var/tmp/rpm-tmp.8EHJsS (%build)
> >
> > ------------------------------------------------------------------------
> >
> > "/usr/bin/make -j4" seems to be the offensive command as best I can
> > tell. I cannot find where the -j4 option is coming from nor what it
> > means. Any ideas anyone?
> Yes, I remember that I've seen this in the past. I don't know how
> you're trying to create the rpm. I did this via "rpmbuild -ba
> data/gnome-commander.spec". Try the following: Open
> "data/gnome-commander.spec" and change the line consisting of
> %{__make} %{?_smp_mflags}
> into
> %{__make}
> This helped in the past when I created an rpm file and when I got the
> same error message. Hope that solves your issue.
> Best
> Uwe
> gcmd-devel mailing list
> address@hidden
> https://lists.nongnu.org/mailman/listinfo/gcmd-devel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]