[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gap-dev-discuss] GNUMail doesn't connect to IMAP Server

From: Riccardo Mottola
Subject: Re: [Gap-dev-discuss] GNUMail doesn't connect to IMAP Server
Date: Tue, 07 Aug 2012 14:38:24 +0200
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120715 Firefox/14.0.1 SeaMonkey/2.11

Hi Sebastian,

Sebastian Reitenbach wrote:

sending this to the GAP list, since the gnustep-nonfsf doesn't have a m/l.

With the Pantomime/GNUMail from GNUstep-nonfsf I always had the problem that
I was unable to connect to IMAP Server. It did not even tried to establish a 
to the IMAP Server. I was looking into it, and found it was trying to find get 
the IP of
the IMAP Server in the CSDNSManager. While parsing the resolv.conf file, and
trying to initialize DNS structure, it did not succeed, and therefore, in 
it then did not tried to connect to the server.

I've seen Riccardo did a lot of things there, but I don't really understand what
he is trying to do. The ChangeLog entry tells me:
         Use res_ninit() on NetBSD to fix long-standing incompatibility

So, reverting the CWDNSManager.[h|m] and the CWTCPConnection.[h|m] to the
files from Pantomime-1.2.0pre3 makes my GNUMail connect to my IMAP Server.
But this may or may not break things again for Riccardo on NetBSD.

As always, I'm on OpenBSD.

Any objections to go back to the older versions, and restart looking into the
NetBSD issue again?

Yes, lots of objections :) My changes are much much smaller, you are comparing too many versions together, with many changes by Ludovic perhaps.. I did the changes to the butlast version, already present in non-fsf and in the past pre-releases. My changes are restriceted to one method and the goal is to use res_ninit() which is thread-safe instead of res_init(). There is the possibility to enable it for one or the other platform. For me it works on Linux and NetBSD if yo udo not require password authentication (see numerous threads on the gnustep ML where I called for help). I Am pretty sure I dod no harm on OpenBSD either. At least, no harm compared to the previous version of the file.


and play with  #define HAS_RES_NINIT 1

As you see, it is enabled only for NetBSD currently. The goal is to test it on other platforms too, since it would be the way to go. As-is my change should not affect other platforms.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]