[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ft] Error when trying to use Freetype library

From: mpsuzuki
Subject: Re: [ft] Error when trying to use Freetype library
Date: Tue, 25 Oct 2005 10:44:15 +0900


Just I want to report that cross-compilation within
Unix world works, at least.

I've tried to cross-compilation of FreeType2 (latest
version checked-out from CVS) on Linux/x86, for Linux/ARM.

        $ env CC="arm-cats-linuxelf-gcc" \
                ./configure --host=i386-pc-linux-gnu
        $ make

is enough. I've grepped cpp outputs and they didn't
include any header files for Linux/x86.

# arm-cats-linuxelf is my toolkit targetted to

However, configure (generated by autoconf-2.59) complains as:

configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.

I think, current autoconf expects new configuration style

        $ ./configure \
                --build=i386-pc-linux-gnu \

But it doesn't work well with current builds/unix/
Before writing patch about this issue, I have to study about
proper cross-compilation setting by autoconf.

And, yet I've not tried on cross-compilation between Linux
and Cygwin etc.


On Mon, 24 Oct 2005 23:29:00 +0200
Fredrik Carlbom <address@hidden> wrote:

>On 10/24/05, Werner LEMBERG <address@hidden> wrote:
>>Have you tried the CVS version of libtool, together with CVS version
>>of autoconf?  Cygwin DLL support is still under development and/or
>>broken partially, I think.
>>Similarly, I'm not sure whether cross-compilation of FreeType works at
>>all.  Any reports (and bugfixes if necessary) are highly welcome.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]