[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ft] Linux newbie having FreeType installation problems

From: Charlie Fiskeaux II
Subject: [ft] Linux newbie having FreeType installation problems
Date: Thu, 20 Oct 2005 18:55:19 -0400

I've using Linux lightly for a year or two on our server at work. I know how to get around it ok, but when it comes to stuff like having to compile/install software on it, I'm out of my league. I've been trying to install FreeType for use with PHP's GD library, but I've been having problems. I'll describe my process:

First, I went to and downloaded 'freetype-2.1.10.tar.gz'. I unzipped it with Winzip 9 and FTP'd the folder up to my server.

Second, I SSH'd into my server, switched to the root user, moved the folder I had uploaded to /freetype, and then copied it to /usr/local/freetype. I then changed the owner and group to root and made sure all the files had executable permissions.

Third, I ran ./configure.
It gave me the message:
Bash: ./configure: bad interpreter: No such file or directory
So after a Google search and some poking around on the server I see that the shebang at the top of the configure file is pointing to /bin/sh, but my /bin/sh is just a link to /bin/bash. So I change the shebang in the configure file to point to /bin/bash.

Fourth, I run ./configure again.
This time I get the message:
cd builds/unix; ./configure
/bin/sh: ./configure: bad interpreter: No such file or directory
make: *** [builds/unix/] Error 126
So I go to builds/unix and use pico to edit the configure file there to change the shebang to /bin/bash and change all other references to /bin/sh so they point to /bin/bash now.

Fifth, I run ./configure again.
I get another message:
cd builds/unix: ./configure
configure: error: cannot run /bin/bash ./config.sub
make: *** [builds/unix/] Error 1
So I go and edit builds/unix/config.sub and change all of its references from /bin/sh to /bin/bash. While I'm there, I do the same for config.guess also.

Sixth, I run ./configure again.
It seems like success! I get a whole long list of things it's checking for, and in the middle it asks, "mv: overwrite 'libtool'?" So I choose yes. It writes some files and then asks me, "rm: remove 'ftconfig.tmp'?" So I again choose yes. So then it spits out the following config info:

Freetype build system -- automatic system detection
The following settings are used:

        platform                                unix
        compiler                                cc
        configuration directory         ../builds/unix
        configuration rules                     ../builds/unix/

If this does not correspond to your system or settings please remove the file '' from this directory and then read the INSTALL file for help.

Otherwise, simply type 'make' again to build the library, or 'make refdoc' to build the API reference (the latter needs python).

make: Nothing to be done for 'unix'.
And that's it for that step.

Seventh, I run 'make'.
Now I'm getting stuff that I don't know what to do with:
./builds/unix/libtool --mode=compile gcc -pedantic -ansi -I/usr/local/freetype/objs -I.builds/unix -I/usr/local/freetype/include -c -Wall -g -02 -DFT_CONFIG_OPTION_SYSTEM_ZLIB -DDARWIN_NO_CARBON -DFT_CONFIG_CONFIG_H="<ftconfig.h>" -o /usr/local/freetype/objs/ftsystem.lo builds/unix/ftsystem.c

: command not foundol:
: command not foundol:
: command not foundol:
/bin/sed: -e _expression_ #1, char 10: Unknown option to 's'
: command not foundol:
: command not foundol:
: command not foundol:
./builds/unix/libtool: line 405: syntax error near unexpected token 'elif'
'/builds/unix/libtool: line 405: 'elif test "X$1" = X--fallback-echo; then
Make *** [/usr/local/freetype/objs/ftsystem.lo] Error 2

What in the world is the problem? Does anyone have any ideas? I really don't know how to troubleshoot this.

Charlie Fiskeaux II

reply via email to

[Prev in Thread] Current Thread [Next in Thread]