[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Freetype] Freetype and old X Terminals..

From: Frédéric BOITEUX
Subject: [Freetype] Freetype and old X Terminals..
Date: Tue, 27 Apr 2004 08:50:49 +0200


  First, excuse-me if my problem can be directly unrelated to FreeType,
but it's not clear for me.

  I'm currently working with some servers running Debian Woody, i.e. with 
old Xfree 4.1.0 and GTK 1.2, and some old X Terminals (NCD Explora 700).
It works fine, and GTK applications (gnome) works well.

  I've tried running newer ones from a Debian Sarge which have :
Xfree 4.3, GTK2.0, Freetype2 and all GTK applications have the same problem :
all texts are completely unreadable !!!
[ look at the picture joined [ I've finally suppressed the attachement to let
my mail arrive to you :-( ]  ]

This problem forbid me to use any new graphical applications (like gnome 2.X) !

I wondered if the problem can come from Freetype, so I tried to run
the freetype demo programs, like ftview, etc. but it doesn't run :

$ ftview 12 /usr/share/fonts/truetype/freefont/FreeMono.ttf 
available pixmap formats
depth  pixbits  scanpad
   1       1       32
   8       8       32
unsupported X11 display depth!
could not allocate display surface

  error = 0x0000

I.E. it seems that the X server on my X terminals (which can display
only with 8bit colors) can't be use with these demo programs.

My questions are :
- do you think my problem can be related or not to Freetype ? if so,
  what can I do ?
- is there a workaround to test FreeType2 on 8bit displays ?

I've already searched on the web without success, only found people
having similar problems, but without solution.

  Thanks for any hint,

        with regards,

        Frédéric Boiteux.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]