[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] Crazy non-Xrun Xruns

From: Ken Restivo
Subject: Re: [fluid-dev] Crazy non-Xrun Xruns
Date: Thu, 28 Dec 2006 12:48:44 -0800
User-agent: Mutt/1.4i

Hash: SHA1

I'm on 0.101.1-2

I didn't see any upstream ChangeLog for jackd, but I generated one from the 
subversion repository, and alas didn't see any mention of multiprocessor or SMP 
fixes. So if that support was added, I haven't been able to figure out at what 
version that was done.

Just to flail around wildly, I tried to build 0.102.20, but neither my 
homegrown uupdate attempt nor the experimental .dsc/orig/diff's from Debian 
(http://packages.debian.org/experimental/sound/jackd) will build for some 
reason, debuild is complaining about not being able to apply the libjack 
versioning patch, oddly..

I did however find mention of jackdmp, which appears to have SMP support, and 
built it and tried it out, but all my jack tools appear to be using SHM, 
whereas jackdmp uses pipes/fifos, so nothing works with jackdmp. Docs say that 
SHM doesn't quite work on jackdmp, nor have I been able to determine how 
well-maintained it is.

I'd expect that most people doing audio work in linux have SMP machines; I'm 
surprised by the idea that JACK doesn't support SMP.

More flailing. Alas, no successes.

- -ken
- --------------
On Thu, Dec 28, 2006 at 06:02:14PM +0100, Florian Schmidt wrote:
> On Thursday 28 December 2006 11:41, Ken Restivo wrote:
> > I don't expect any answer to this, but it's making me very sad.
> >
> > Advanced Linux Sound Architecture Driver Version 1.0.14rc1.
> > Compiled on Dec 28 2006 for kernel (SMP).
> >
> > And an ugly hda-intel sound card, on a Mac Mini.
> >
> > jackd starts up fine, in realtime mode.
> >
> > But then.
> >
> > If I launch any fluidsynth, I get endless reams of:
> >
> >             delay of 5099.000 usecs exceeds estimated spare time of 
> > 4982.000; restart
> > ...
> >
> > No combination of parameters to jackd appears to fix it.
> >
> > If I kill the fluidsynths, the error messages persist. qjackctl interprets
> > them as Xruns, even though I don't actually get Xrun messages, just the
> > above.
> Do you have a recent jackd version? There were problems with timing on SMP 
> once...
> Flo
> -- 
> Palimm Palimm!
> http://tapas.affenbande.org
Version: GnuPG v1.4.1 (GNU/Linux)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]