[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Fenfire-dev] Repost: PEGs swamp_easier*--benja

From: Tuomas Lukka
Subject: Re: [Fenfire-dev] Repost: PEGs swamp_easier*--benja
Date: Mon, 29 Sep 2003 11:11:45 +0300
User-agent: Mutt/1.5.4i

On Sun, Sep 28, 2003 at 06:18:52PM +0300, Benja Fallenstein wrote:
> Hi,
> (After replying to the individual points of your mail, I've come up with 
> a potential compromise we should discuss; you may want to skip to the 
> end of this mail to read it first.)
> Matti Katila wrote:
> >On Sat, 27 Sep 2003, Benja Fallenstein wrote:
> >
> >>The (now) two related PEGs about the Swamp API, swamp_easier--benja and 
> >>swamp_easier_iteration--benja: please say whether all of your comments 
> >>have been addressed!
> >
> >Umh, two pegs in one post is not good at all :/
> Would having two related pegs in two different posts have been better?

Yes, and I think *first* the one about TripleIter, and wait with the
other until that's accepted (since I think we can accept TripleIter pretty
soon now).

> >I think we did have some misunderstanding about the peg split last time,
> >since I was saing that I don't have any cons related to iterating trought
> >triplets instead of nodes.
> In other words, you would be fine with swamp_easier_iteration--benja, 
> but not with swamp_easier--benja.
> >But having in the same beg that
> >find_ [IXA] things should be removed and replaced with findSubject etc. is 
> >about method naming but not about iterating triplets.
> These are *not* in the swamp_easier--benja PEG, so what's the problem?

It's confusing to have two PEGs at the same time with similar names, one of 
relies on the other...

When splitting a PEG, it would probably help to keep them sequential as
I said above.

*You* know exactly what's in either of them but we, the others, would like
to see one well-rounded complete idea at a time.

> For the second, I prefer ``iter.subj`` etc., but we *could* use ::
>     iter.xoo
>     iter.oxo
>     iter.oox

Urrrgh! No! Horrible!

> which would use the position.
> For example, my types example would become::
>     for(TripleIter i = graph.find(_, RDF.type, _); i.loop();) {
>         System.out.println(i.xoo + " is instance of " + i.oox);
>     }
> What I do *not* want is having *both* ``oxo`` and ``pred``, because that 
> would mean users have to understand both in order to be able to read our 
> code.
> What do people think of this compromise?

This is *not* right...

Hmm, something like 


might be good...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]