[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ESPResSo-devel] name REACTIONS feature

From: Peter Kosovan
Subject: Re: [ESPResSo-devel] name REACTIONS feature
Date: Thu, 14 Mar 2013 15:00:07 +0100

Dear all,

First a warning: I think there is a bug in the default behaviour of the reaction when k_back is not specified. I will consult it with Georg and submit a bug report if necessary.

My suggestion is to call the feature CATALYSIS or CATALYTIC_REACTION.

The current REACTION feature of Espresso implements a reaction of the type

A = B (catalyzed by catalyst X)

i.e. when A or B collide with catalyst X, they can change the identity. For this particular reaction, only one specific kinetic scheme is implemented. From the current ug it is not clear if reactants or products can be more than one species but the tcl implementation expects one integer for reactants and one for products, i.e. only one species can be involved.

In my view, the name REACTION should be reserved for the more general case which might be implemented in future. For me as a chemist, a generic reaction is represented by the equation

a*A + b*B = y*Y + z*Z (eventually involving catalyst or intermediate X)

where A,B, are reactants, C, D are products and a,b,c,d are stoichiometric coefficients. Both left and right hand side may involve an arbitrary number (>0) of reactants or products. Catalyst X (if involved) itself does not undergo a chemical change but may be required for the reaction to occur. The "=" sign (in literature denoted using \rightleftharpoons) indicates that each chemical reaction can run in both directions although in many cases one direction dominates.

With regards,


On Tue, Mar 12, 2013 at 5:51 PM, Joost de Graaf <address@hidden> wrote:
Hi Everyone,

Recently there has been some talk about changing the name of the
REACTIONS feature, since it might cause some confusion. Should we go
for a more descriptive name? If so, what should this name be and how
should we implement the name change, i.e., such that people will know
that as of ESPResSo version 3.2 or so the feature has a new name.

KR, Joost

reply via email to

[Prev in Thread] Current Thread [Next in Thread]