[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug: no math-mode detection for align-environment [9.3.7 (9.3.7-13-g

From: Stefi
Subject: Re: Bug: no math-mode detection for align-environment [9.3.7 (9.3.7-13-ge62ca4-elpaplus @ /home/stefi/.emacs.d/elpa/org-plus-contrib-20200713/)]
Date: Wed, 26 Aug 2020 20:05:47 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.10.0

I can also confirm that org-try-cdlatex-tab outputs "t" in all cases but
does not expand in align environment.

I noticed that cdlatex-env-alist-default does not include the align
environment. I tried to add it to "Cdlatex Env Alist" in the customize
browser but it did not change the behavior to what I expect.

I skimmed through cdlatex.el but did not find anything suspicious. I am
not a hardcore lisp coder though.

On 8/26/20 5:44 AM, Kyle Meyer wrote:
> Stefi writes:
>> Hi Kyle, hi mailing list,
>> I also evaluated (org-inside-LaTeX-fragment-p) and got non-nil values
>> for all blocks, however, inside the align* environment, the "fr" does
>> not get expanded on TAB whereas it does in equation environment. So
>> either the matchers do not include align/align*, or there is something
>> different now with cdlatex.
> I'm leaning towards there being something different with cdlatex.
> I've now installed cdlatex from
> <https://staff.fnwi.uva.nl/c.dominik/Tools/cdlatex/cdlatex.el>.  The
> file header says the version is 4.8, and the file's md5sum is
> 9246a4e9f30c9589406783ffd5270641.
> I tried your example file with this minimal configuration:
>     (require 'org)
>     (add-hook 'org-mode-hook (lambda () (org-cdlatex-mode 1)))
>     (require 'edebug)
>     (edebug-instrument-function 'org-try-cdlatex-tab)
> As you and Rafael report, "fr => \frac{}{}" is not expanded in the align
> or align* environments, while it is expanded in the equation
> environment.  However, stepping through the org-try-cdlatex-tab call,
> cdlatex-tab is called in all cases.  So it would seem that something has
> changed downstream.
> In line with this idea, I observed the same behavior with both the
> latest commit of the master branch (cdfc404be) and v9.2 (released in Dec
> 2018).  Also, as I mentioned in earlier in the thread, I don't see any
> recent changes on Org's side related to the cdlatex functionality.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]