[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] using orgtbl-sqlinsert

From: Eric Abrahamsen
Subject: Re: [O] using orgtbl-sqlinsert
Date: Wed, 25 Sep 2013 09:29:17 +0700
User-agent: Gnus/5.130008 (Ma Gnus v0.8) Emacs/24.3 (gnu/linux)

Carsten Dominik <address@hidden> writes:

> Hi Eric,
> do you have orgtbl-to-sqlite defined?  What does it look like?
> Do you have the BEGIN RECEIVE and END RECEIVE lines in the buffer?
> Are you working in a buffer that is not in Org-mode?  Do you have orgtbl-mode 
> turned on?

Hi Carsten,

I later replied to that thread (at least, I think it should have been
part of the same thread) with a patch to orgtbl-to-sqlite. Bastien
applied it, and to my knowledge all is well. As Jason mentioned, this
and I guess the other orgtbl-* functions seem sort of out of date at
this point (should they all be replaced with Babel?), but the problem I
brought up here, at least, is fixed.


> On 26.5.2013, at 08:56, Eric Abrahamsen <address@hidden> wrote:
>> I've got a table I'm trying to insert into a sqlite database. I've been
>> looking at orgtbl-sqlinsert and this page[fn:1], but I suspect all that
>> is out of date. I haven't seen anyone talking about #+ORGTBL: keywords,
>> or things like "#+BEGIN RECEIVE ORGTBL exsql" in the past year or so.
>> Do those still work? I can't for the life of me get it to do anything.
>> I've got a sqlite database called "market.sqlite" in the same directory
>> as a file containing this:
>> #+TBLNAME: terms
>> #+ORGTBL: SEND market.sqlite orgtbl-to-sqlinsert :sqlname "terms"
>> | Chinese          | English                            |
>> |------------------+------------------------------------|
>> | 音像制品出版     | A/V Publishing                     |
>> | 定价总金额       | Aggregate Retail Price             |
>> (etc)
>> I've tried C-c C-c on that header, calling
>> `org-babel-execute-src-block', waving my fingers at it, and cursing
>> loudly, one of which usually works. But I get no error, no insertion
>> into the database, and no results block with INSERT statements (I tried
>> making a #+BEGIN RECEIVE ORGTBL marketdb.sqlite block as noted on worg).
>> Does this still work? Or is it still possible to jimmy orgtbl-sqlinsert
>> to either insert directly, or create a block of INSERT statements?
>> Thanks!
>> Footnotes:
>> [fn:1] http://orgmode.org/worg/org-tutorials/multitarget-tables.html

reply via email to

[Prev in Thread] Current Thread [Next in Thread]