[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] bug#14605: Problem with export an .org file to .pdf does not ope

From: Glyn Millington
Subject: Re: [O] bug#14605: Problem with export an .org file to .pdf does not open pdf file
Date: Wed, 18 Sep 2013 06:21:36 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

Matt Price <address@hidden> writes:

> On Tue, Sep 17, 2013 at 5:25 PM, Glyn Millington
> <address@hidden> wrote:
>> Carsten Dominik <address@hidden> writes:
>>> On 17.9.2013, at 15:56, Suvayu Ali <address@hidden>
>>> wrote:
>>>> On Tue, Sep 17, 2013 at 09:04:45AM +0100, Glyn Millington wrote:
>>>>> Carsten Dominik <address@hidden> writes:
>>>>>> On 17.9.2013, at 08:01, Matt Price <address@hidden> wrote:
>>>>>>> On Tue, Sep 17, 2013 at 12:42 AM, Matt Price
>>>>>>> <address@hidden> wrote:
>>>>>>>> On Tue, Sep 3, 2013 at 5:12 AM, Achim Gratz
>>>>>>>> <address@hidden> wrote:
>>>>>>>>> Or you could leave it in and see who complains.  The
>>>>>>>>> instances where xdg-open doesn't work or is not correctly
>>>>>>>>> configured will probably be in multi-user / corporate
>>>>>>>>> environments where it is unlikely that the newest Org or
>>>>>>>>> Emacs is installed anyway.
>>>>>>>> Hi,
>>>>>>>> I'm running today's org with a recent emacs-snapshot in a
>>>>>>>> single-user linux environment (ubuntu 13.04).
>>>>>>>> xdg-open xxx.html works fine when run from the command line,
>>>>>>>> but from inside org-mode it seems to fail to run In
>>>>>>>> particular, html, odt and pdf documents no longer seem to open
>>>>>>>> from the export menu, even though the log in *Messages*
>>>>>>>> reports that the relevant command
>>>>>>>> ("xdg-open-my-org-file.html") has been run.
>>>>>>  Is there anyone else who has tried the xgd-open way to follow
>>>>>> links with Org?
>>>>>  Yes, I have the same symptoms as Matt.
>>>>> GNU Emacs 24.3.1 (x86_64-unknown-linux-gnu, GTK+ Version 3.8.2)
>>>>> Org-mode 8.1.1 (the latest ELPA package fails in the same way)
>>>>> xdg-open works on the command line but not through the org-export
>>>>> menu - pdfs and html files don't open automatically.  There are
>>>>> no error messages.
>>>>  I see the same problem.  But I think this might be an Emacs
>>>> issue; I can't open a pdf from dired either (with & on a pdf
>>>> file).  However I can open it if I execute a shell command: M-!
>>>> xdg-open file.pdf RET.
>>> Do I need to conclude that, for the time being, xdg-open has to be
>>> removed from the default value of org-file-apps?
>> That did the trick - pdf files now open as before, as do html
>> exports.
> Glyn, can you just tell me what you set org-file-apps to? I wasn't
> able to find a value that worked.  Thank you!

Having checked on the git page and seen that Carsten reverted the changes
that caused the problem, I cleared out my elpa installation and cloned
the git repository!  The value I now have, the default, is:

 ((auto-mode . emacs)
 ("\\.mm\\'" . default)
 ("\\.x?html?\\'" . default)
 ("\\.pdf\\'" . default))

The changes are listed here:


diff --git a/lisp/org.el b/lisp/org.el
index 0cf141c..0762696 100644
--- a/lisp/org.el
+++ b/lisp/org.el
@@ -1899,13 +1899,9 @@ single keystroke rather than having to type \"yes\"."
:type 'regexp)
(defconst org-file-apps-defaults-gnu
- (append
- '((remote . emacs))
- (if (executable-find "xdg-open")
- '((system . "xdg-open %s")
- (t . "xdg-open %s"))
- '((system . mailcap)
- (t . mailcap))))
+ '((remote . emacs)
+ (system . mailcap)
+ (t . mailcap))
"Default file applications on a UNIX or GNU/Linux system.
See `org-file-apps'.")



reply via email to

[Prev in Thread] Current Thread [Next in Thread]