[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: The new keymap functions

From: Juri Linkov
Subject: Re: The new keymap functions
Date: Wed, 17 Nov 2021 10:10:40 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/29.0.50 (x86_64-pc-linux-gnu)

>> What about renaming it to `keymap-define'?  Then:
>>   (keymap-define "C-c C-c" #'quit-buffer)
>>   (keymap-set map "C-c C-c" #'quit-buffer)
> I like that all the `keymap-*' functions take a map as the first
> parameter (except the commands that have the map "in the name", like
> `keymap-global-set').  And using `define-*' for a form that defines
> something (and has a (potentially) long body) is a very long-standing
> tradition in Emacs, so I'd prefer to keep it as is.

This is fine.  I see that `define-key' avoids this dilemma
by removing `define-' in its replacement `keymap-set' 🙃

The reason why I'm asking this is to know how the corresponding
function/macro for repeat-mode should be named in master.
And it seems `define-repeat-map' would be the right name.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]