[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Windows Binaries Release: was The emacs-28 release branch

From: H. Dieter Wilhelm
Subject: Re: Windows Binaries Release: was The emacs-28 release branch
Date: Tue, 02 Nov 2021 13:05:54 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.60 (windows-nt)

Hello Phil

I'm a bit unsecure about the naming of the git/ folders.

What do you mean by "git/emacs-$branch"? For snapshots, I think, it is
"git/master", not "git/emacs-master"?  This variable $branch pains me...

Then for the emacs-28 branch must it be named "git worktree
emacs-emacs-28"?  or is it just "emacs-28" but then wouldn't it clash
with the release branch emacs-28?  Sorry, it's still a bit confusing, I
think I've to fully understand the build scripts...


Phillip Lord <phillip.lord@russet.org.uk> writes:

> "H. Dieter Wilhelm" <dieter@duenenhof-wilhelm.de> writes:
>> Hello Phil
>> Phillip Lord <phillip.lord@russet.org.uk> writes:
>>> They aren't anywhere accessible, because they are a bit specific to my
>>> use.
>>> But for instance, I use one called "build-emacs27.sh" which essentially
>>> looks like:
>>> rm -rf ~/emacs-build/build
>>> rm -rf ~/emacs-build/install
>>> cd emacs-27/admin/nt/dist-build
>>> ./build-zips.sh -g
>>> ./build-zips.sh
>> I created such a script but my problem is that chmod seems not to work
>> for me!
>>    chmod u+x build-zips.sh
>> doesn't change anything, so I can't run the scripts.  Do you know this
>> problem?
> I'd need an error message. build-zips.sh needs to be run in a mingw64
> shell, and build-deps-zips.py in an msys2 shell (for obscure reasons
> that I don't really understand).

Thanks.  I mistakenly tried to run the scripts in an *eshell*!

>>> Then I have "build-27-deps.sh" which again is just a launch script.
>>> set -o errexit
>>> if test -f emacs-src; then
>>>     rsync -r emacs-src emacs-src-cache
>>> fi
>>> rm -rf i686 x86_64 emacs-src
>>> ../git/emacs-27/admin/nt/dist-build/build-dep-zips.py -s 2>&1 | tee
>>> build-deps.log
>>> cp emacs-27* ~/emacs-upload
>> I don't get here the "emacs-src" and "emacs-src-cache" folders, they
>> aren't mention in README-scripts.  Do I have to create them by hand?
> build-deps-zips should create them both at the same time. The cache is
> useful because it means you don't need to download the source every
> time. This step also tends to error and my script can't recover from
> this, so the cache means it can pick up from where it left off.

I see, thanks for the clarifiation.

>> So I tried to run build-dep.zips.py -s by hand for (a snapshot) but I
>> haven't had luck:
>> Please have a look at the end and tell me which MSYS2 package contains
>> /mingw64/bin/ntldd?  I don't see it in the system and in pacman
>> Traceback (most recent call last):
>>   File 
>> "/c/Users/uidg1626/emacs-build/deps/../git/master/admin/nt/dist-build/build-dep-zips.py",
>>  line 267, in <module>
>>     gather_deps()
>>   File 
>> "/c/Users/uidg1626/emacs-build/deps/../git/master/admin/nt/dist-build/build-dep-zips.py",
>>  line 71, in gather_deps
>>     for dep in full_dll_dependency():
>>   File 
>> "/c/Users/uidg1626/emacs-build/deps/../git/master/admin/nt/dist-build/build-dep-zips.py",
>>  line 83, in full_dll_dependency
>>     deps = [dll_dependency(dep) for dep in DLL_REQ]
>>   File 
>> "/c/Users/uidg1626/emacs-build/deps/../git/master/admin/nt/dist-build/build-dep-zips.py",
>>  line 83, in <listcomp>
>>     deps = [dll_dependency(dep) for dep in DLL_REQ]
>>   File 
>> "/c/Users/uidg1626/emacs-build/deps/../git/master/admin/nt/dist-build/build-dep-zips.py",
>>  line 88, in dll_dependency
>>     output = check_output(["/mingw64/bin/ntldd", "--recursive",
>>   File "/usr/lib/python3.9/subprocess.py", line 424, in check_output
>>     return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
>>   File "/usr/lib/python3.9/subprocess.py", line 505, in run
>>     with Popen(*popenargs, **kwargs) as process:
>>   File "/usr/lib/python3.9/subprocess.py", line 951, in __init__
>>     self._execute_child(args, executable, preexec_fn, close_fds,
>>   File "/usr/lib/python3.9/subprocess.py", line 1821, in _execute_child
>>     raise child_exception_type(errno_num, err_msg, err_filename)
>> FileNotFoundError: [Errno 2] No such file or directory: '/mingw64/bin/ntldd' 
>> Thank you for your assistance
> It's a mingw64 package. Building requires the full toolchain.
> mingw-w64-x86_64-ntldd-git - MSYS2 Packages

Perfect, I'll install it!

Have a nice time


reply via email to

[Prev in Thread] Current Thread [Next in Thread]