emacs-bug-tracker
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#61459: closed ([PATCH] gnu: node-lts: Remove dependency on python-wr


From: GNU bug Tracking System
Subject: bug#61459: closed ([PATCH] gnu: node-lts: Remove dependency on python-wrapper.)
Date: Wed, 22 Mar 2023 18:23:01 +0000

Your message dated Wed, 22 Mar 2023 14:21:58 -0400
with message-id <874jqchcjd.fsf_-_@gmail.com>
and subject line Re: bug#61459: [PATCH] gnu: node-lts: Remove dependency on 
python-wrapper.
has caused the debbugs.gnu.org bug report #61459,
regarding [PATCH] gnu: node-lts: Remove dependency on python-wrapper.
to be marked as done.

(If you believe you have received this mail in error, please contact
help-debbugs@gnu.org.)


-- 
61459: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=61459
GNU Bug Tracking System
Contact help-debbugs@gnu.org with problems
--- Begin Message --- Subject: [PATCH] gnu: node-lts: Remove dependency on python-wrapper. Date: Sun, 12 Feb 2023 20:47:20 +0100
From: Jelle Licht <jlicht@fsfe.org>

This also reduces the closure size of node-lts from 255 MiB to
172 MiB (on x86_64-linux).

* gnu/packages/node.scm (node-lts)[inputs]: Remove PYTHON-WRAPPER.
---
 gnu/packages/node.scm | 1 -
 1 file changed, 1 deletion(-)

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index be39f3b25a..6137ed1dd3 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -887,7 +887,6 @@ (define-public node-lts
            brotli
            `(,nghttp2 "lib")
            openssl-1.1
-           python-wrapper ;; for node-gyp (supports python3)
            zlib))))
 
 (define-public libnode
-- 
2.39.1




--- End Message ---
--- Begin Message --- Subject: Re: bug#61459: [PATCH] gnu: node-lts: Remove dependency on python-wrapper. Date: Wed, 22 Mar 2023 14:21:58 -0400 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.2 (gnu/linux)
Ludovic Court├Ęs <ludo@gnu.org> writes:

> Hi,
>
> jlicht@fsfe.org skribis:
>
>> From: Jelle Licht <jlicht@fsfe.org>
>>
>> This also reduces the closure size of node-lts from 255 MiB to
>> 172 MiB (on x86_64-linux).
>>
>> * gnu/packages/node.scm (node-lts)[inputs]: Remove PYTHON-WRAPPER.
>
> LGTM! :-)

Applied!

-- 
Thanks,
Maxim


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]