[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#36689: closed (27.0.50; calc can't show grouped he

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#36689: closed (27.0.50; calc can't show grouped hex numbers)
Date: Tue, 16 Jul 2019 15:44:01 +0000

Your message dated Tue, 16 Jul 2019 17:43:21 +0200
with message-id <address@hidden>
and subject line Re: 27.0.50; calc can't show grouped hex numbers
has caused the debbugs.gnu.org bug report #36689,
regarding 27.0.50; calc can't show grouped hex numbers
to be marked as done.

(If you believe you have received this mail in error, please contact

36689: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=36689
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 27.0.50; calc can't show grouped hex numbers Date: Tue, 16 Jul 2019 23:07:08 +1000

0. Start clean Emacs with "emacs -q"
1. Enter some numbers into calc
2. Switch to hex display with "d r 16"
3. Turn on grouping with "d g"
4. Observe error message "calc-do: Symbol’s function definition is void:

In GNU Emacs 27.0.50 (build 4, x86_64-w64-mingw32)
 of 2019-07-16 built on SATURN
Repository revision: 288e83ae00fcf6da8064ecb5a8ffaec202c5e9ec
Repository branch: master
Windowing system distributor 'Microsoft Corp.', version 10.0.18362
System Description: Microsoft Windows 10 Pro (v10.0.1903.18362.239)

Recent messages:
For information about GNU Emacs and the GNU system, type C-h C-a.
Welcome to the GNU Emacs Calculator!  Press ‘?’ or ‘h’ for help, ‘q’ to quit
Number radix is 16
calc-do: Symbol’s function definition is void: math-format-hex
Configured using:
 'configure --with-modules --without-imagemagick 'CFLAGS=-O3 -g0

Configured features:

Important settings:
  value of $LANG: ENA
  locale-coding-system: cp1252

Major mode: Calculator

Minor modes in effect:
  tooltip-mode: t
  global-eldoc-mode: t
  electric-indent-mode: t
  mouse-wheel-mode: t
  tool-bar-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  buffer-read-only: t
  line-number-mode: t
  transient-mark-mode: t

Load-path shadows:
None found.

(shadow sort mail-extr emacsbug message rmc puny dired dired-loaddefs
format-spec subr-x rfc822 mml mml-sec password-cache epa derived epg
epg-config gnus-util rmail rmail-loaddefs text-property-search time-date
seq byte-opt gv bytecomp byte-compile cconv mm-decode mm-bodies
mm-encode mail-parse rfc2231 mailabbrev gmm-utils mailheader sendmail
rfc2047 rfc2045 ietf-drums mm-util mail-prsvr mail-utils calc-mode
calc-misc calc-bin calc-alg calc-ext cl-loaddefs cl-lib calc-menu
easymenu calc calc-loaddefs calc-macs elec-pair tooltip eldoc electric
uniquify ediff-hook vc-hooks lisp-float-type mwheel dos-w32 ls-lisp
disp-table term/w32-win w32-win w32-vars term/common-win tool-bar dnd
fontset image regexp-opt fringe tabulated-list replace newcomment
text-mode elisp-mode lisp-mode prog-mode register page menu-bar
rfn-eshadow isearch timer select scroll-bar mouse jit-lock font-lock
syntax facemenu font-core term/tty-colors frame cl-generic cham georgian
utf-8-lang misc-lang vietnamese tibetan thai tai-viet lao korean
japanese eucjp-ms cp51932 hebrew greek romanian slovak czech european
ethiopic indian cyrillic chinese composite charscript charprop
case-table epa-hook jka-cmpr-hook help simple abbrev obarray minibuffer
cl-preloaded nadvice loaddefs button faces cus-face macroexp files
text-properties overlay sha1 md5 base64 format env code-pages mule
custom widget hashtable-print-readable backquote threads w32notify
dbusbind w32 lcms2 multi-tty make-network-process emacs)

Memory information:
((conses 16 74976 9681)
 (symbols 48 8817 1)
 (strings 32 22581 2064)
 (string-bytes 1 642324)
 (vectors 16 10894)
 (vector-slots 8 140243 13462)
 (floats 8 29 259)
 (intervals 56 301 0)
 (buffers 992 14))

--- End Message ---
--- Begin Message --- Subject: Re: 27.0.50; calc can't show grouped hex numbers Date: Tue, 16 Jul 2019 17:43:21 +0200
Thank you, now fixed in master. Neither hex nor octal worked; the functions 
were simply missing.
Binary worked, but it used funny 0-padding; probably a result of the recent 
bignum change in 1bc1672f77.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]