[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Duplicity-talk] Difficulties with restore: 'Could not restore the f

From: andrew
Subject: Re: [Duplicity-talk] Difficulties with restore: 'Could not restore the following files. Please make sure you are able to write to them.'
Date: Fri, 12 Nov 2021 16:02:17 +0000
User-agent: Roundcube Webmail/1.4.2

Hi ede/everyone,

To investigate why duplicity wasn't restoring the email files which I mentioned then I ran this:

duplicity restore -v9 --file-to-restore home/awood/.thunderbird file:///run/media/awood/MyPassport/Deja-Vu-Back-up/ home/awood/.thunderbird > output.txt

I've attached the outputfile which is 3.7 MB. There were also some libsync errors which I guess were being output on stderr?

Best wishes,


Andrew Wood, Oxford

- o -

On 11/11/2021 12:49, edgar.soldin--- via Duplicity-talk wrote:
On 10.11.2021 20:20, andrew via Duplicity-talk wrote:

I hope you're keeping. I've run into a difficult with duplicity and I am at a loss to understand the difficulty. Any suggestions would be appreciated.

I have been using Déjà Dup on Fedora 33 for weekly backups of my home directory which includes a hidden Thunderbird directory. I installed Fedora 35 and tried using restore (Backups 42.8). While this has successfully restored most of the files, it hasn't been successful with some Thunderbird files - but not all of them!

For example:

/home/awood/Documents/myDocuments/Thunderbird-gnapcorg10nov2021/pop.gn.apc.org/Mail/Local Folders/Inbox /home/awood/Documents/myDocuments/Thunderbird-gnapcorg10nov2021/pop.gn.apc.org/Mail/Local Folders/Inbox.msf /home/awood/Documents/myDocuments/Thunderbird-gnapcorg10nov2021/pop.gn.apc.org/Mail/Local Folders/Sent /home/awood/Documents/myDocuments/Thunderbird-gnapcorg10nov2021/pop.gn.apc.org/Mail/Local Folders/Sent.msf /home/awood/Documents/myDocuments/Thunderbird-gnapcorg10nov2021/pop.gn.apc.org/Mail/Local Folders/Trash /home/awood/Documents/myDocuments/Thunderbird-gnapcorg10nov2021/pop.gn.apc.org/Mail/Local Folders/Trash.msf

At the end of the restore then these files are listed along with 'Could not restore the following files. Please make sure you are able to write to them.'

I can't think of any reason why they couldn't be written - there's definitely space on the disk. I also tried to restore the back-up on Ubuntu and I had the same message.

Any suggestions? Thank-you.

hey Andrew,

we need more details. could you please run duplicity with maximum
verbosity '-v9' and put the full command line output to pastebin or
the like and post the link here? obfuscate information you deem
private in it beforehand!

..regards ede/duply.net

Duplicity-talk mailing list

Attachment: output.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]