[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Duplicity-talk] boto vs boto3 backend

From: ml
Subject: [Duplicity-talk] boto vs boto3 backend
Date: Sat, 11 Jul 2020 22:05:23 +0000


I am using duplicity 0.8.14 with the s3 backend to write to a Scaleway C14
Glacier storage (similar to Amazon S3 Glacier). Scaleway provides an
s3-compatible API and this is actually working very well.

When using boto (with a target url of s3://s3.fr-par.scw.cloud/my-bucket)
this works very well. But I can't get it to work with a boto3 backend. As I
understand it boto is outdated and boto3 should be used if possible.

I tried it with boto3+s3://s3.fr-par.scw.cloud/my-bucket which leads to:

  botocore.exceptions.ClientError: An error occurred (403) when calling the 
HeadBucket operation: Forbidden

I also tried with boto3+s3://my-bucket.s3.fr-par.scw.cloud as I read that
only that subdomain bucket addressing would be supported by boto3, but I
actually don't know if that would work out-of-the-box or needs to be
explicitly supported by Scaleway. It leads to exactly the same error as

What I also don't understand is the example for boto3 in the duplicity
manual stating to use


There is no host specified in that URL. How am I supposed to specify the
host of my provider?

So, what is the actual problem here? What can be the reason that boto
works, but boto3 doesn't?

Is boto somehow deprecated? Or will it be supported "forever"?

Is boto3 Amazon-only or should it work with third-party providers providing
an s3-compatible API?

Best regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]