dtas-all
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 1/2] setup: update to use RbConfig


From: James Rowe
Subject: [PATCH 1/2] setup: update to use RbConfig
Date: Sun, 1 Dec 2019 20:03:48 +0000

`Config` was removed years ago┬╣, and is not supported in any Ruby release
that dtas supports.

1. https://bugs.ruby-lang.org/issues/6809
---
 setup.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/setup.rb b/setup.rb
index 9f0c826..65380f4 100644
--- a/setup.rb
+++ b/setup.rb
@@ -785,7 +785,7 @@ def ToplevelInstaller.load_rbconfig
     else
       require 'rbconfig'
     end
-    ::Config::CONFIG
+    ::RbConfig::CONFIG
   end
 
   def initialize(ardir_root, config)
-- 
2.20.1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]