[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Dragora-users] dragora-installer: Partition detection issues

From: Michael Siegel
Subject: Re: [Dragora-users] dragora-installer: Partition detection issues
Date: Wed, 20 Nov 2019 20:42:09 +0100
User-agent: Mozilla/5.0 (X11; Linux i686; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

Am 20.11.19 um 18:34 schrieb Matias Fonzo:
> El 2019-11-20 13:05, Michael Siegel escribió:
>> Am 20.11.19 um 03:13 schrieb Matias Fonzo:
>>> I've prepared a new package in case you want to try it:
>>> http://rsync.dragora.org/current/packages/x86_64/tools/dragora-installer-20191119-x86_64+1.tlz
>>> http://rsync.dragora.org/current/packages/x86_64/tools/dragora-installer-20191119-x86_64+1.tlz.sha256
>> Thanks!
>> But this won't really work on a 32-bit system, right? Unfortunately, I
>> don't have a 64-bit machine available for testing, at the moment.
> I thought you were going to test it for x86_64.  Packages for i586 are
> also available:
> http://rsync.dragora.org/current/packages/i586/tools/dragora-installer-20191119-i586+1.tlz
> http://rsync.dragora.org/current/packages/i586/tools/dragora-installer-20191119-i586+1.tlz.sha256

Ah, okay. Should have had a look into the i586 directory...

Now, I booted the Dragora live system from a CD, then rsync-ed those
files over from a USB key.

Next, I used fdisk to create the following partition layout on the
machine's hard drive:

Disk /dev/sda: 74.54 GiB, 80026361856 bytes, 156301488 sectors
Disk model: SAMSUNG HM080HC
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xbb7736d2

Device     Boot    Start       End   Sectors  Size Id Type
/dev/sda1  *        2048  20973567  20971520   10G 83 Linux
/dev/sda2       20973568  23070719   2097152    1G 82 Linux swap / Solaris
/dev/sda3       23070720 156301487 133230768 63.5G 83 Linux

Then I ran the updated installer script and got the following error message:

    Linux partitions were not detected.

A Linux partition is required to continue the installation.  You can
use utilities such as fdisk(8), cfdisk(8) or parted(8) to create at
least one Linux partition.  Then run `dragora-installer' again.

^ Return status = 1

I don't know why this happens. Maybe I didn't sync the files correctly.
I used

  rsync -rv usr/ /usr
  rsync -rv var/ /var

from the USB key that had the directories with the updated files. And as
far as I could tell from rsync's output as well as looking at the output
of some ls -l commands, that had all worked as expected.

Any ideas?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]