[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Dolibarr-bugtrack] [Bug #496] Can't add a predefined product in Invoice

From: Doliforge
Subject: [Dolibarr-bugtrack] [Bug #496] Can't add a predefined product in Invoice Supplier
Date: Wed, 06 Mar 2013 22:01:46 +0100

Is this email not displaying correctly?
update email preferences.

Can't add a predefined product in Invoice Supplier

Latest modifications

2013-03-06 22:01 (Europe/Paris)
Bug can't be reproduced on last develop version or may be
obsolete because of changes, so we suppose it was silently fixed.
Because of this, we close the request.
  • Status: 

Answer now


Submitted by:  Stephen Larroque (lrq3000) Submitted on:  2012-08-16 13:35
Last Modified On:  2012-10-18 14:19 Dolibarr version:  develop
PHP version:  5.3.5 Database type and version:  5.5.8
OS Type/Version:  Windows 7 Pro 64-bit Category:  Module Invoice supplier
Severity:  5 - Major 
Summary:  Can't add a predefined product in Invoice Supplier
Description:  It's impossible to add a line with a predefined product (but free form product works) in invoice supplier.

Tested on the latest develop version on github of today (16/08/2012).
Step to reproduce bug:  There are 2 different bugs here:

- either don't set any supplier price for this product. Then the product will still be available to add as a predefined product on an invoice supplier (with the AJAX mention that no price was defined), but when submitted, the error message says "The Description field is mandatory", which is not the real reason of rejection (because description was filled).

- either fill a price for this product and supplier, but then when trying to add this product, the AJAX will timeout (the loading gif image will stay on screen and never go away, and the product will never be found). In this case, if you still submit (with the exact name of a product, mine was called "aaa" so it was easy to remember), the same error message as previously will be shown ("Description is mandatory").
Resolution:  Works for me Assigned to:  Régis Houssin (hregis)
Status:  Closed 


Laurent Destailleur 2013-03-06 22:01
Bug can't be reproduced on last develop version or may be
obsolete because of changes, so we suppose it was silently fixed.
Because of this, we close the request.
Laurent Destailleur 2012-10-18 14:19
Do you still have problem with last cvs version ?
Laurent Destailleur 2012-08-27 12:26
There is a lot of regression for the moment on selection of products to add line, I suggest to wait few weeks before everything is solved.
Stephen Larroque 2012-08-27 02:19
On the demo it works as you said. Since I don't have admin rights, I can't check the differences of the system and constants with mine.

Anyway, my setup is totally standard, database included, no core file modified or anything else. Maybe this is a bug that happens only on Windows systems, or on very rare cases.

If you tell me a bit about how AJAX works in Dolibarr, I can maybe try to track and debug where this bug comes from. Or just drop this bug meanwhile until someone else reports it.
Laurent Destailleur 2012-08-26 18:35
I can't reproduce too.
Can you reproduce on ?
Stephen Larroque 2012-08-23 20:05
Oui tout est défini, et l'ajout des produits fonctionne sans AJAX (le produit s'affiche alors bien dans la liste déroulante, et je peux l'ajouter sans problème), par contre dès que je met l'AJAX (que ce soit à 1, 2 ou 3 caracteres), ca bug. L'option PRODUCT_DONOTSEARCH_ANYWHERE n'est pas activée (tout de moins elle n'est pas définie dans mon install et ne l'a jamais été).
Régis Houssin 2012-08-23 18:04
est-ce que tes produits ont un prix fournisseur de défini ?
Stephen Larroque 2012-08-23 14:09
Another thing: adding predefined products work when the AJAX option is not enabled (using an HTML dropdown box), but when we enable the AJAX option, it won't work anymore.

I tested on clean installs of:
- Dolibarr v3.1.1
- Dolibarr v3.2.0 final
- Dolibarr v3.3 of today on Github

All of them have the behaviour I've described.

If you can give me some guidelines on how to debug that I'll be happy to do that (where to look at? how to print results in AJAX using JQuery to debug?).
Stephen Larroque 2012-08-23 13:50
Bug is still there.

Tested on the latest version version on Github of today.

Another element that is interesting: now that I fixed the supplier order bug (so that I can now access them), the same bug happens for this module.

Thus it seems that supplier's modules are affected by an AJAX bug. Maybe a wrong path somewhere? I'm not really into JQuery so here I'm a bit more cautious...
Régis Houssin 2012-08-18 07:12
I can not reproduce your problem, I just tested and everything works!
Stephen Larroque 2012-08-17 22:59
I just tested the latest develop branch, it still does not fix the problem.

I also tried to fill the Description field of the product, but it doesn't work. But what's weird is that it does not work either with Dolibarr v3.2.0!

Also, there is a mini description box for the predefined product line in v3.3, when in v3.2.0 there's none (there's only the ref field).

I'll try to take a look, but I did not yet know any of the AJAX code of Dolibarr, may take a while.
Régis Houssin 2012-08-17 19:39
The bug has been corrected inside GIT sources

So fix should be available with next stable release.
Stephen Larroque 2012-08-17 18:41
Ah do you mean the form was talking about the Description field of the product, and not the description field of the line?

I'll try it and post back the result.
Marcos García 2012-08-17 07:16
I think I understood you, so let me explain:

Both predefined product/service and free line share the same form action, so, if a product is not available to be chosen, it will think that you are adding a free line, so because of the Description field being empty, it throws that error.

I don't have any problem adding a predefined product...
Stephen Larroque 2012-08-16 13:37
May be a duplicate of this question, but some of the description is not quite the same:

Also, while the other bug was fixed, this one is still not.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]