[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using GnuStep on a day to day basis, strange basic bugs

From: Riccardo Mottola
Subject: Re: Using GnuStep on a day to day basis, strange basic bugs
Date: Wed, 27 Jan 2021 11:47:51 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.53.6

Hello Tomaž,

Tomaž Slivnik wrote:
> Hi,
> I've tried using GnuStep several times as a day-to-day work environment,
> but I always give up after I soon run into basic bugs which make the
> experience unworkable. I've decided to give it another go and try to get
> to the bottom of these bugs.

I'm sorry to hear that. I do use it daily instead, I need to eat my own
dog food :)

> Right now, I opened GWorkspace and opened a RTF file. It opened in Ink.
> I tried to open it in TextEdit, so I tried right-clicking on it. I was

As a suggestion: open the Tools inspector. There you can see all
registered applications for a certain extension. You can set the
default, but also open with another application.

E.g. if I look at a TIFF image, I have the following:

> not successful, but I did end up with two menus stuck on the screen
> which are not functional and which can be neither moved nor closed. I
> attach the screen shot.

That's bad.

> What is the cause of this?
> How do I get rid of these menus?

I don't know. The GWorkspace menu is the main menu, it can only be moved
around or quit when quitting the application.
A sub-menu like Edit should get a "quit" button like a window as soon as
you drag it around. I think there is some bug.
What windowmanager are you using?

> How do I associate the RTF extension with TextEdit rather than Ink?

The easiest way is the "Set default" I mentioned above.

> PS I am on Debian 10.5, and I'm using the latest GnuStep package. 
> GWorkspace says it's 0.9.4. TextEdit says it is release 5.

I don't think it is a TextEdit issue, more probably gnustep gui or back,
it could be specific to the debian install.
0.9.4 is last GWorkspace release, there are unreleased fixes, but
nothing that justifies your behaviour.

> PPS What is the best Unix-line system (Linux / FreeBSD / etc.) to use
> GnuStep with?

Debian/Devuan work perfect for me - but I configured and compiled all
gnustep packages by myself, Gentoo is my tool of trade for GNUstep
development since my dawn of GNUstep and it continues to work well.
OpenBSD and FreeBSD also do work well. NetBSD works well when using gcc
runtime, with the libobjc2 runtime I'm trying to see if I can smooth out
things with David.
But as always, I compile all GNUstep stuff myself: it just "proofs" that
the OS behind is good and in case proves that there are package
specifics issue with the supplied packages.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]