[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using GnuStep on a day to day basis, strange basic bugs

From: Svetlana Tkachenko
Subject: Re: Using GnuStep on a day to day basis, strange basic bugs
Date: Sun, 24 Jan 2021 13:34:58 +1100
User-agent: Cyrus-JMAP/3.5.0-alpha0-78-g36b56e88ef-fm-20210120.001-g36b56e88

Hi Tomaž

Debian 10 user here, gworkspace.app 0.9.4-1+b2

An RTF file opens in 'Grr' for me, with an ``NSInvalidArgumentException: 
RSSFeed(Instance) does not recognise setSuperElement`` error. Boo.

Right-clicked the file > GWorkspace main menu > File > Open with...; this 
works. Brings up a prompt, where I am able to type `/usr/bin/libreoffice', and 
the file opens with libreoffice. I do not know path to the textedit binary file.

Perhaps re-installing TextEdit package can help?

Svetlana Tkachenko
Associate Member of the Free Software Foundation
http://www.fsf.org http://www.gnu.org

Tomaž Slivnik <slivnik@tomaz.name> написал(а):
> Hi,
> I've tried using GnuStep several times as a day-to-day work environment,
> but I always give up after I soon run into basic bugs which make the
> experience unworkable. I've decided to give it another go and try to get
> to the bottom of these bugs.
> Right now, I opened GWorkspace and opened a RTF file. It opened in Ink.
> I tried to open it in TextEdit, so I tried right-clicking on it. I was
> not successful, but I did end up with two menus stuck on the screen
> which are not functional and which can be neither moved nor closed. I
> attach the screen shot.
> What is the cause of this?
> How do I get rid of these menus?
> How do I associate the RTF extension with TextEdit rather than Ink?
> Many thanks.
> Tomaz
> PS I am on Debian 10.5, and I'm using the latest GnuStep package. 
> GWorkspace says it's 0.9.4. TextEdit says it is release 5.
> PPS What is the best Unix-line system (Linux / FreeBSD / etc.) to use
> GnuStep with?
> Attachments:
> * Screenshot from 2021-01-23 11-59-11.png

reply via email to

[Prev in Thread] Current Thread [Next in Thread]